Failed setup flashing green light


I have looked through a lot of posts but cant find one that seems to match my issues so hoping someone may be able to help me!

~I have a 1TB My Book Live connected up to my network router.  Have got my laptop hard wired to router as well.  (although I have tried wireless and a different computer too)

When I first tried to setup the drive i could see the drive but the first thing I did was do the firmware update and now the drive green light is flashing all the time as if the drive is busy and the setup program (and WD link) cannot locate the drive.

However what is very odd is I can see the drive in windows explorer in the network section and I can copy files to it and see the public folders that are on the drive.

I just cant seme to set it up using the software and therefore cannot access any of the features of the drive!

I have tried to access support but cannot get past the login screen even though I have registered my product and can login to that part of the WD site.

Hope someone may be able to help.



If you can access the my book shared folder then you don’t need the WDlink app. To access the dashboard, just go to any web browser and enter you can also change “mybooklive” for the my book IP address. On the link below you can see the tech support phone number.

I have tried the but get some dodgy looking search website!

I cant use the IP address as I dont know what it is, I cant access any features on the mybook, I cant get dashboard to work and the normal setup software will not discover the drive.

The green light is flashing and this should be a soid light when its not doing anything.

I havent rung support yet but does anyone have any other ideas?