WD My Live Book

I have a WD My Book Live WDBACG0030HCH-00 which I am unable to set up. I have connected on network and it continues to show green LEDs and I cant search this disk via software or any other way. I would appreciate any help started with this so  that atleast I can use this hard disk. Thank you, Rakesh

Hi, welcome to the community.

Have you tried resetting the drive? How are the leds on the NIC (network interface card) of the drive?

I tried resetting the drive and I  can access it via IP address on browser now. LEDs are green however not able to search this drive via WD Live software. I use Windows 10 on my PC. I would appreciate your help. Thank you, Rakesh


I am new to this broad so please bear with me, i am having the same problem with my WD My Book Live WDBACG0030HCH-00. I have now turn it if for a few minutes and re-connected, the LCD is now blue (which has now been blue for 3 hours) and i have remove the app/program from my computer and table/phone, i have do this to update to the new various.

Now I can not correct at all and the Book Live is making a reboot noise every few minutes (like its trying to wake up), Please help!!

My book is 2.3GB full and i really do not want to lose anything.

Thank you for your time.