Error in RAID Configuration

I seem to be in the same boat. Has anyone discovered a resolution for the problem?

I am the same as everyone else. Has anyone found out how to fix this?!

Drive: My Passport for Mac - 500Gb

Desktop: Mac Mini running Mavericks

Issue started occuring tonight.

I started getting the exact same error tomight also.

Not sure if it started completely on its own or if I actually did something, but the drive had been working for many many months until now.

I have now managed to get it working again, and have been pulling my data off it as I will be replacing it now.

This is what I did…

Go to Activity Monitor and look for a process called fsck_hfs.

If this is running, force quit it.

Then look for any of the WD programs, and force quit them…I came across a few called wdhelper, wdsecurty, wddriveutilities etc etc.

Force Quit all of them.

Then unplug your drive. Wait 10-20 seconds, plus it in again, and you shoudl see the WD Unlocker app appear.

Pop it open and unlock your drive.

You should now have access, and from what I can see, continue to have access (I pulled a 14Gb file from mine with no issues) .

What I have discovered is that the moment you open one of the other WD applications … WD Security, WD Drive Utilities it seems to dismount the drive.

Also verifying and running repairs on the drive in Disk Utility, seem to cause it to dismount.

Needless to say, all my data is getting downloaded and moved elsewhere…my trust is gone

I am having exactly the same issues as everyone else described.  I’ve tried all the recommended solutions with no success. Will be returning this drive to Best Buy and purchasing another.  Frustrating!

Had the same error. After removing the WD Utilities and killing all WD related processes everything worked just fine for me. 


At least, it was a solution for me.

I was having this same problem, didn’t happen until I updated to El Capitan

I called apple, and had GREAT support from them, and we found the solution to my problem

There is “wd drive utility” software that would launch upon start up

go here to delete it:

FINDER - GO - COMPUTER - LIBRARY - LaunchDaemons - com.wdc.WDPrivilegedHelper.plist


Then, go to 


That fixed the porblem for me, had the issue on 2 of my 4TB WD MY BOOKS

So glad that apple helped me solve the problem, props to them! Hope this helps you guys!


I had been having this issue this morning with a WD Passport 2TB and 2008 MacBook Pro (on 10.7.5). So far (…) I seem to have got round the problem, initially in response to bjcreative’s post.

Following bjcreative’s solution, I’m not on El Capitan (I’m on 10.7 so there is no ‘LaunchDaemons’ folder in my Library folder, so I didn’t delete anything there. I also checked that the WD Drive Utility was unchecked in the Users & Groups on System Prefs.

Having noted that people had reported issues around WD utilities needing to be shut down in Activity Monitor etc I decided to just uninstall the WD Utilities package, for good measure I also deleted the WD Security which I had installed when I first plugged in the drive.

I did a restart on the MacBook Pro and hey presto (touch wood etc) everything is working fine at the moment.

My guess is that the WD Utilities does regular background checks on the drive and that somewhere along the way this had created a conflict within the system. Whatever the reason the drive appears to be working fine now.

PS: I had also been having problems with random disconnection of the drive and it was looking as though the MacBook’s USB drive was not providing enough power. I’m happy to say that since uninstalling WD Utilities there has not been a disconnect…!

1 Like

Bjcreative’s post helped. Was having the same problem as everyone.

At first the daemon file wasn’t there to be deleted. I actually went to wd’s site and re downloaded the utility. After it was installed I went into to completely remove the utility.

After it was completely uninstalled, I went back to the daemon file and it was there to delete. So, I deleted it… I also went into system preference and did the uncheck thing, but it wasn’t there. So that was that.

Finally, I restarted the computer, plugged in the HD, and presto… it showed up and remained connected.

I have amazon prime, so i’m currently uploading 509GB incase the HD fails in any way again. I must say, I do feel proud to have figured it out, being an total novice, with the help above of course. Thanks for calling Apple!! It was the trick. This was super frustrating…

Nice to see the caring support of WD here… they must just lock us in a room and leave us scream to death rather than fix stuff. I was unable to find the LaunchDaemon anywhere, however, after downloading a new utilities installer it gives an uninstall option which I took. Then going to the main device library not user the launch daemon could be found.

Looks to me this WD My Passport Ultra which worked fine in the past is not fit for purpose as a reliable back up device and is more or less sold devoid of any useable support software leaving you to rely on The Apple Disk tools or if you have a third party app like Disk Warrior or Drive Genius as I do. You then may as well buy a vanilla off the shelf drive off eBay as pay premium WD prices. I just bought a new 3TB Passport a few weeks ago and feel robbed already. Its a shame as I came to WD after similar appealing decline in support and respect for customers data at Iomega a few years ago… and it also looks like removing the launchdaemon has not stopped the drive firing the warning messages every few minutes which makes the use of the drive an irritation when doing other stuff.

Thanks for the help people!! it worked!!

Unless you restart after removing the files the launch Deamon is retained in Memory

Just suffering from the same error (OSX 10.11.4, latest version WD Drive Utilities) on an older 2 TB drive and a brand new one. There is not any RAID configuration for this 2 TB drive, so not sure what’s going on here.

Like others uninstalled WD’s Drive Utilities. The only benefits are 1) you can check the drive via S.M.A.R.T. and 2) change a RAID config for e.g. Thunderbolt Duo, 3) change the sleep timeout.

Think it started to pop up after I updated to 10.11.4 on tuesday.

I updated my iMac to OS X 10.11.4 two days ago and ever since then I’ve been getting a notice popping up stating “Error in RAID Configuration” on “My Book” and “My Passport”…I’ve been on the phone with Apple for hours trying every possible solution but no luck resolving the problem. After finding this forum and reading what others have done to resolve the problem I Uninstalled WD Utilities. I was also getting a notice stating “Disk Not Ejected Properly” Eject “My Book” before disconnecting or turning it off. I had both Passport and Book set to back up and never in three years ever experienced this problem until the update to OS X 10.11.4 so as others have done it seems the only way to resolve it was Uninstall…I hope WD comes up with a solution so Utilities wll work as it should…

Update, even after Uninstalling WD Utilities the problem still exists, I had to remove “My Book” from Time Machine to correct the problem. “My Passport” seems to be running fine. I might try reinstalling WD Utilities and see what happens.

Like the last couple of commenters, I started seeing error messages after updating to OS 10.11.4, and waking computer from sleep. I did not, however, lose any functionality with the MyBook Studio, which is partitioned for Time Machine and other data purposes.

I did delete the WD utilities and other items noted by Bjcreative. It will be interesting to see if I get error messages again.

You may also want to check login items in your user. I had both helper apps listed to run whenever I logged in. I started getting the error messages after the 10.11.4 upgrade, too. No unmounts, though.

I’ve also started getting this error since installing OSX 10.11.4.

Error only shows up when I wake the system after it’s been in sleep mode overnight, and only for the drive I use for Time Machine backup. My other My Passport Ultra drive hasn’t reported any problem.

Neither WD Drive Utility or Apple’s Disk Utility find any issues with the drive.

What I’ve conclude is this, the “My Book” that I have is not compatible with Time Machine after the 10.11.4 update so I took it off line for back ups via Time Machine…and it triggers a RAID Configuration Error message with WD Utilities installed. The 1TB “My Passport” which I originally had a problem with has been corrected by doing an update on the firmware…I’ve since ordered a 3TB My Passport for MAC which specifically states it is compatible with Time Machine so I can have a dual backup drives…

I have the same issue. I am using OS 10.11.4 and I get the ‘raid configuration error’ message every time I wake my iMac from a long sleep - most frustrating. My ‘My Passport Ultra 2TB’ drive is not being used for Time machine backup but as my iTunes media storage.

When I try to eject the drive I need to ‘force eject’ it as something is apparently using it even when iTunes/Quicktime have been quit - the only apps which I can think would actually be using files from the drive.

Has anyone found any resolutions to this problem? Is it definitely a firmware issue?

*iTunesHelper is my only login item switched on.
*I have already deleted the ‘com.wdc.WDPrivilegedHelper.plist’ file
*Quickly sleeping/waking my iMac doesn’t seem to generate the error.

After waking up, does the error message clear on its own? I have the same issues (iMac, 10.11.4), and am using the MyBook Duo as my Time Machine backup drive (2TB, RAID 1). After the drive spins up upon waking my iMac (primarily I only see this after sleeping overnight), the pop-up message eventually disappears, apparently once the software realizes the RAID does not have an error.