3 TB WD DRIVE for Mac is gett ERROR in RAID Configuration

Lately my WD DRIVE started to pop up with a message that said “Error in RAID configuration. Your device MY BOOK for mac (S/N WMC**********) has RAID configuration issues. Please launch the WD drive utilities software to get more information.”
Why is this pop up keep coming back?? How to fixed this? Please help!


If you open the WD drive utilities, are you getting any specific errors.

If you are getting this error, might be possible that the RAID mode might be degraded.

I’m having the same problem as Joseph. It started happening immediately after upgrading from Yosemite to El Capitan. I’ve run the WD drive utilities, including the hours long scan, and no errors were found. The drive seems to be working okay, but having to click through the error message is indeed annoying.

I am getting the same problem after updating to El Capitan. I guess its comforting to know others are getting the same problem and it seems to be OS based and not drive based. I’ve run all the checks and scans as well with no errors found. On another note, is anyone else able to update the firmware on their drive? I cannot as it says my drive is not supported.

When utilities is open, I run 3 test. 2 pass, the last one fail to complete. Anyway, i got respond from WD and they ask me to uninstall my utilities, so I did. Not sure if this will solve the problem, but so far nothing popup like b4.

I’m having the same problem, but with a 4 TB drive. Suggests the size of the drive is probably not the issue. I’ll try Joseph’s suggestion about reinstalling the WD Utilities. I’ll share the results.

Incidentally, WD Utilities, Disk Utility, Tech Tool 8, and Drive Genius 4 all report the disk as having no problems; and, so far, it’s worked flawlessly. Sill, with this unresolved I can’t trust it. To parody Dale Carnegie, WD, you’ve found a way to Win Friends (among your competitors, to whom you’re sending customers who used to be yours) and Influence People (influencing them not to trust your brand).

kill WD daemon seems to address the issue. He got support from Apple on how to remove the WD daemon from Mac OS X