Easy method to downgrade to previous version of the firmware

Thank you for your aswers dubie and lotust251!

I had always problem with media scaning, so I tried tutorial from lotust251’s link. It’s written great, thanks for it.

Now I downgraded to v030401-230 firmware and cloud seems to be in very good condition, fast good response, everything seems to be OK:-) Thanks you once again for your help.

But I have problem when I connect to Cloud my USB disc WD MyBook. After while Cloud doesn’t response. The response stops after I want to load and see my previous safepoints from USB. Without USB Cloud works OK. I will try to solve it next days, but if you have some ideas I will be very happy. 

I have had the same problem since day 1. Doesn’t matter which firmware version I use, if I connect the My Book via USB to the My Cloud, the My Cloud drops off the network.

glad I could help.  This is what a good forum does.   help each other 

Nice that you successfuly downgraded the firmware. Now, I recommend you perform a “system only restore” from the dashboard under Settings - Utilities. Again, turn off media scanning and itunes server once it boots. Make sure the USB drive is disconnected first. It would be a good opportunity to wipe all the hidden files and kill the media scanning services as I mentioned in my previous post.

Before you connect the USB drive to the MyCloud again, plug it into your PC and check the disk for errors.

I did the downgrade with no problems. But if wha you said cant hurt to do. Definity make sure the drive is off.

General rule of thumb is for one to load up the Mycloud with your data slowly. I had 2tb of pics and movies and music. I had the media server on the whole time. I drive indexed and made thumbnails for 4 days! lol seriously.

Thank you for your answers guys. As I wrote before I had still problems after successful firmware downgrade – problems after connecting USB disc with cloud response and updating my previous safepoint. So I realized some advices from dubie and cloud now works very good :smiley:

First I made system restore only, after that I stopped media and itunes server and restarted. Through this I checked my USB WD MyCloud on PC – everything was OK. At first it didn’t help but after 2nd restart and waiting a few minutes after start it was good and cloud worked with USB disc correctly - I saw previous safepoint and I updated it manually and in the night automatically too. I used cloud for 3 days and I successfully updated safepoint again with no problem and response is OK. It appears that everything is OK – now I see the remaining capacity, safepoints, I have access with wd2go.com and from smartphone app WD my cloud (only WD Photos doesn’t work). I can recommend and help with this procedure everybody who has similar problems.

But I want ask some other things. I want use DLNA media server with my TV and itunes server with itunes app. What do you think, when I turn these servers on, will also cloud work correctly?

And I didn’t do one thing, I didn’t wipe all the hidden files and kill the media scanning services as dubie recommend on http://community.wd.com/t5/WD-My-Cloud/Hidden-wdmc-directories-created-by-mcserver-and-photodbmerger/td-p/682091. I admit that I didn’t understand the aim and what will happens when I do this. Does it influence media and itunes servers? I know this is the other theme it will be better I write there, but I will be very happy if you can simple explain me the aim of deleting the .wdmc hidden folders and disabling wdmcserverd and wdphotomergerd.

Tomas,

There is a nice explanation from Raphael about the media scanning service in his post here: http://community.wd.com/t5/WD-My-Cloud/before-you-pack-up-your-WD-and-return-it-let-s-talk-about/td-p/683307

You have to scroll half way down the first post to the heading " Finally the problem with WD Cloud"

I’m not so sure about using Twonky and itunes. I have turned these off as I do not need them. Hopefully someone else will answer.

Hi!

I tried to downgrade the firmware to the version suggested in this post, but it fails saying:

Upload firmware fail. Try again.

I tried, but the result is the same. One thing I’ve noticed is that after I change the version in the version file and reboot the device, the version number is restored to the original one (1.05.30). After that attempt to download the sq-030401-230-20140415.deb file to the device fails with the error above. Any suggestions?

Are you sure that you unzipped the firmware deb file after you downloaded?

1.05.30 firmware is for the My Cloud Mirror.  WD took back my My Cloud and gave me a My Cloud Mirror and I am not seeing any issues with backups or connecting my 3TB My Book (used to crash the My Cloud).

As you can see I mentioned .deb and not the .zip file, so yes, I unzipped the file.

What I have is My Cloud EX2.

I left the My Book connected to My Cloud over night and I can see the My Book share now and can browse the file on the My Book device.

The My Cloud EX2 Dashboard page is still inaccessible.

So is there a cure for this condition beside downgrading the firmware?

By the way, the device reports that it runs the lates firmware when checking for firmware updates.

Though everything looked normal, I tried to move files from My Book to My Cloud EX2 and My Cloud EX2 became unresponsive, so ufter all it was not ok.

This guide was written for the regular MyCloud device, not the EX2. I don’t know how these two devices differ, but perhaps you should flash the EX2 firmware back to its original?

The My Cloud EX2 forum is here.

I have already posted this in the OP’s first post, but…

Users, please be aware that making changes to your drive through SSH can void your warranty.  Moreover, downgrading may cause other issues with the drive.

If you’re not sure what to do, please contact support for further help.

@Bill_S

Ok, we understand and we already know that! But what we must do to not lose the warranty and still be able to use the cloud?

I see only one solution: Replace the cloud or take the money back!

JS

Have you contacted support about this, first.  If you need help with this, I can help out.

All I can say is that Level 2 support has known about this for more than 1 year.  They could never get my My Cloud to work with my My Book attached.  Never got a Safepoint to run and when the My Book was attached, the My Cloud would drop off the network.  Tried downgrading the firmware with no luck.  In the end, they swapped it out for a My Cloud Mirror.  More stable but still has issues backing up to the My Book.

I’m sorry, but I’m starting to get confused. I will look into the My Book issue.  Which My Book were you attempting to use?

What issue were you having, exactly?  I don’t want to get confused with different issues here.  If they are.