DLGDIAG for windows has stopped working

I tried to run the tool WD Data Lifeguard Diagnostic v1.28 for Windows but it crashes just after it starts, when clicking “Next” with the License Agreement box checked. I tried running it with all the compatibility modes but nothing seems to work.

Can anybody help me please?

Hello,

I recommend you try downloading it again. also, if possible try it on another computer.

I have the same problem too. I tried it on different computers and it still doesn’t work. Can someone from WD please fix this issue.

Thanks :slight_smile:

I’m the 3rd person to report this problem, having registered here in order to do so. I imagine there must be others who have given up without registering. I’ve tried downloading several times and followed the instructions to the letter but the program still comes up with the DLGDIAG for Windows Has Stopped Working message while detecting drives, before opening the program. Clearly there is an issue with the program. I’m using Windows 7 64 bit on a HP PC with a WD drive.

I think I found a solution.  I was having the exact same problems as the other posters on this thread, and running Win 7 64-bit as well.  From the dates on this thread t seemed like this problem started happening somewhat recently.  This led me to wonder if the problem was with the latest version of Data Lifeguard Diagnostic (1.28)

I couldn’t find an older version anywhere on WD’s site, but I found version 1.24 on cnet, right here:

http://download.cnet.com/Data-Lifeguard-Diagnostic-for-Windows/3000-2086_4-10972008.html

That version works for me with no problems!

If anyone from WD is listening: If looks like with the latest update, you’ve broken the program for many people with certain OS configurations.  It seems silly that you don’t host previous versions of the software on your own site, as this is a pretty common thing with software updates.

Anyway, hope this info helps some folks out, since Western Digital clearly has no intention of helping us.

Same problem for me on Windows 10. Had 1.28 installed. Upgraded to 1.29 then uninstalled and installed 1.24. Nothing helped. Same problem. Trying to ensure a new Black drive is in good shape after having some bad files after a 1.4TB copy over from another drive.

Same problem here>

Unplug any USB Thumb drives you have plugged in.
I had this same problem until I unplugged an 8 Gig USB Thumb drive.
See DLGDIAG for windows crashes

4 Likes

The same for me with 1.29: immediate crash after clicking “Next” with the License Agreement box checked, tried “run as administrator” also. No USB drives present, but there are of course not only WD drives in system: OS(windows 7 X64) is running from SSD and 2nd SSD is also present. Is there any known workaround: maybe I should just try older version of dlgdiag? My drive is old(2011?) “green” WD30EZRX.

Thanks Greg, that worked for me! x)

I found the issue was caused by my memory card reader. Disconnecting it from the motherboard USB header and reconnecting it cleared the issue.

The reader had no memory cards in it at the time but still caused the fault. Ok now.

1 Like

To aid WD in diagnosing this issue, here are my system specs and the resolution:

System Specs:

  • OS: Windows 7 Ultimate 64-bit (SP1)
  • RAM: 16GB

App Settings:

  • Version: 1.29
  • Compatibility Settings: None
  • Running As Admin: True

Root Cause: I had a “SanDisk” USB 3.0 128 USB drive plugged in.
Solution: I unplugged it and the application worked with out any issues on windows 7 64 bit. No compatibility settings used

Thanks this was my solution, removed usb thumb drive and worked fine even though a WD drive is still pluged into another USB port.

Awesome fix!

WD Please fix this. It is a huge pain to have to decipher what components need to be disconnected. I had to disconnect the one that my drive I wanted to diagnose was connected to. Your diagnostic program should not crash while checking local drives connected whether they are connected via SATA, USB or eSata. How am I supposed to diagnose my drive if I cannot connect it to my computer? I should not have to open up the computer and connect it to an internal sata connector.

FIX THIS it has been broken for far too long now!

Carl

To heck with this. I am just going to RMA the drive and you can test it.

Same issue here. At install/run dialog, I get an error message saying DLGDIAG for Windows has stopped working. I’ve tried to uninstall and reinstall, and download several times, and I get the same thing each time.

Also tried to disconnect a card reader from mobo, and same result.

I’m wrapping up a new build using RAID 10 w/ (4) WD Black 2tb drives. Intel RST says one of the drives has an error, and I need to troubleshoot it. DLG was recommended on Tom’s Hardware by Boogieman_WD. I appreciate the advice from a company rep, but advised software at least needs to work.

I also have this problem with 1.29. Why hasn’t it been fixed? I don’t have any connected thumb drives to remove! Data Lifeguard Diagnostic for Windows crashes while starting.

Same problem … no solution …

I completely uninstalled … and reinstalled new from WD download

as of say June 2016 this app did work … have not used since then …

found specific guidance in other thread that helped me … after rereading the posts in this thread there are similar suggestions … posting what worked for me …

Same problem. Disabling the 8 or so USB controller items in device manager under the USB controller group did the trick… after i did this the app did not crash and appears to function normally … after i am done with my diagnostics i will reenable the USB items

My pc is a dell optiplex x64 running W10. I upgraded to W10 since the last time i used the lifeguard diagnostic app. But prior to the W10 upgrade … running on W7 i used the app many times with no issues and with same USB ports / hardware … ie i did not have to disable the USB hardware under W7 for the app to run.

I any number of steps prior to this simple fix to resolve the crashing app … i uninstalled and reinstalled all the C++ distributables … i did a repair of the OS … and other things … nothing mattered

I would call this a bug in the WD data lifeguard app … should be more robust or give more specific error message such as USB conflict please disable unused USB …

1 Like