DL4100 as Master Browser

Naturally, wife needs to be on the network all weekend so no firmware upgrade to the router this weekend. However, Newegg has the RT-N66W (white version of the RT-N66U) on sale for $49.99 so I ordered one. Once I receive it and upload the latest firmware on it, it will take all of five seconds to do the swap and she will be none the wiser. Plus, it will allow me to take my time swapping the RT-N66U back to stock firmware from DD-WRT in case something goes wrong. Once updated, the RT-N66U will return to router duty and the RT-N66W will become an Access Point on my home network.

Great price; I just looked an now they are “on sale” for $87 (includes $20 off). So, hope you got yours at $50 sale price. (I missed seeing that deal, although for over two years I got one on sale at Newegg, and it is still sealed, and to be used if current one ever goes poof.

Suggestion: keep the white one set up as router, bring it on vacations made by car; bring the drive you will attach to it, and use it as a “wireless drive” wherever you are! I have a router just for that purpose. I got the idea from a post in the WD My Net forum, and took the idea and ran with it. See my link:

In fact, I took it even further; I ran across an eBay deal recently on a discontinued new, open box, MyNet 900 Central router (the one with the 1TB drive in it) Copied my My Cloud media to it, and on next car vacation it goes with us! I have a couple of wireless hard drives, but they are all 2.4G band, and with this router I have faster 5G to stream from.

If you want an AP, get a range extender instead. Here is a link to a company that has been liquidating the entire WD My Net line for a couple of years. They still have the WD Range Extender (new) for only $30 bucks. Great price for something that once listed for around $100. I have two set up; one for 2.4G band and one for 5G band. They do the job to get full house coverage!
http://grassrootscomputers.com/collections/frontpage/products/wdbapk0000nch

Yep, the My Net line did not sell well. WD’s loss, our gain.

1 Like

Today only!
$69.99 With Promo code EMCETGH22 plus $20 mail in rebate = $49.99

I bought two of the My Net Wi-fi range extenders on your suggestion. Where do I find the latest firmware for them though? I can’t seem to find the download file on Western Digital’s site.

The RT-N66W will now go into “save-for-when-the RT-N66U-dies-one-day” storage once I am done with it.

Thanks for the great ideas! I might do the 2TB MyNet N900 for the wife’s SUV. Although I probably will re-wire its fan to the power supply inlet so it runs continuously while on. From reading the forum posts, it looks like it might have a tendency to get hot.

Well, this conversation is starting to cost both of us some real $$$ for more toys! Thanks for the tip on the newest Newegg ad that came this morning, apparently, and I did not look.at it. So. I got one of these Asus “White Knights” tonight right before the deal closed. Let’s both remind one another to be sure to take advantage of the $20 rebate and do all the paperwork. I have been know to blow off a few, accidently! BTW. I saved the PDF that gives all the rebate “rules” so if you didn’t, let me know, and I can get it to you.

I also have the Range Extender FW zip file I downloaded from WD when it could be found last spring. I had a friend buy one, too, and needed the FW to update his, and I have it saved. I will send you a PM and tell you where to D/L it from my Cloud. I knew I would need it, for other REs I have stashed away in case the ones I run now go poof.

I told you I have two running, but I didn’t tell you the whole story. I have another second one for 5G. that has the EXT suffix added (explained in the manual which is at WD, so get it downloaded.) I did this because I noticed that when my new Fire TV stick cut my bandwidth speed slightly when it was streaming, so I hooked up another RE with EXT tacked onto name of extender and problem was gone. So, both the Fire stick and Chromecast2 are my only devices connected to this second one which is parked right next to the devices on the entertainment cabinet. If I add another 5G device there later, it too, will be connected to this extender. The phones and tablets are connected to the non-EXT 5G router and RE.

Now you have some good reasons to have more than two range extenders, and you know where to get more at a good price.

The only devices connected to our 2.4G signal are our growing collection of Amazon Echos, since they don’t require 5G; all they stream is music and no video. We started out with the original Echo last year, but with the release of the new Dot and Tap end of March, we now have those around the house, too. Fun gadgets. Listening to Tap play TuneIn radio station right now on the portable Tap…

It’s kind of a problem finding FW for older WD products since the revamp of their support site this year. The My Net forum here gave me some clues and I went googling for them. I found this link below for the My Net routers, but the RE FW is not listed. The site I am about to give you links directly to the FW on the WD server, and although the links are not public at WD anymore they still work! So, this is how I found the FW for the new My Net N900 Central router, and apparently you may need it, too.
http://downdrivers.com/firmware/down-drivers-western-digital/:

I know a forum member who seems to know the links for many WD FW links; I will send him a PM and ask him what his secret is for finding them.

Continuing on from above . . .

OK, so I asked the forum member, and he told me his secret is to use Google. Well, duh, so that’s what I do, too, but this time I googled the exact name of the latest firmware, and got two hits. So, google for:
My_Net_Wi-Fi_Extender_v1.02.01.zip

and you will get same info I did where you can download it from the wdc.com server. so no need for me to post the FW for you.

The RE user manual tells you how to install the FW manually:

"To update from a file:
1. Locate the firmware file on the WD Support site at
http://support.wdc.com and download it to your computer.
2. On the extender screen, click Browse and locate the firmware file you saved.
3. Click Open. The file name displays in the browser field on the extender screen.
4. Click Upload. A message says how long the upload will take. Please wait while the
firmware update is taking place"

BTW, there was only one update of the FW for the RE; this one.
You may not even need it since some of the REs I bought had it installed and some did not. So check what version is installed after you turn it on.

Lastly, here is the link for the user manual at WD:

1 Like

Hi,

I received my RT-N66W today, did you? You will likely get yours installed before I do, so can you let me know what FW version is originally installed on it before you update the FW? It can indicate how “fresh” our units are. Hope it is a real current version.

Let me know how it all goes for you. I also have a WHITE, unopened Motorola SB 6141 modem I have had for over a year that I need to install, too, so the two unit will match! It doesn’t really matter, because both are kept near a CAT5e distribution box in an upstairs walk-in closet. Wi-Fi signal gets through the sheetrock wall to center of home just fine. Router distributes wired signal at CAT5e box to 4 Ethernet wall outlets around the house.

Do you have any comments regarding my last posts of last week, above?

I received mine yesterday and got it setup tonight. I didn’t note down the FW version before upgrading but it was older. I used Asus’ original firmware 3.0.0.4.378.9529 as my upgrade FW.

I could not, however, find the setting on the Asus WebGUI for the router to set it as the Master Browser.

OOPs! Doh! I need to plug a USB drive into it like you stated in your post on April 14th. Well…off to do that now and will report back.

Hooray! Success! With the USB hard drive attached, the router became the Master Browser on the network! I now know two ways to get this done on my network (the router and the Synology NAS). It’s too bad that WD Support never even got back with me (I guess they are stumped as well why the DL4100 does not work as a MB), but thanks to mike27oct, I now have a solution to my original problem and some new things to try out on the network as well.

I haven’t received my two WD My Net Wi-fi REs yet but now I do understand how to get the latest FW installed (if necessary).

Once I installed my RT-N66W as my main router (while I re-flash the firmware from DD-WRT back to Asus FW on my original RT-N66U router), I noticed that my RT-N66R that functions as my wireless bridge downstairs quit connecting. Just FYI, it’s a pain to reset the N66s whilst in bridge mode because you have to hardwire connect them to a computer to do so.

I also have the same modem as you and I use Comcast as my ISP. I like the modem and the channels bond nicely.

OK, I see you have things running with the new Asus. Glad you found my earlier comments about it and the MB. You seem to have figured out to put a drive on the router, and turn on BOTH the “Cloud Disk” and “Smart Access” (you don’t need to turn on Smart Sync unless you will use their cloud service. You now have your MB!

Something to know about the drive on the router. I use a HGST Touro, a 1TB little portable drive attached to mine. This drive goes to sleep if not accessed after about 10 minutes. This is good as it rarely gets used much since getting my DL2100. It also has a database on it called minidlna, and I am pretty sure it is the Asus router that creates it for the media on it; not the drive.

It got corrupted for the first time a couple of months ago after I deleted and then added a bunch of music files. The drive ran continuously (abnormally) for a few days until I took it off and put it on PC to take a look. I did a test, and effectively removed the minidlna files and put them in a folder and out of the root folder. I put the drive back on router and right away removed the drive again, and looked at it on the PC and the minidlna got recreated. So, I deleted the new one that was not populated, and put drive back on router again, and the minidlna was recreated and went ahead and did its cataloging thing overnight, and when the lights on drive had ceased blinking later in morning, I knew the database was finally completed and examined it again on the PC. It was now a large file again, but hopefully no glitches in it now. It’s been a couple of months and all is still well.
No mention of minidlna file in Asus manual, but it darn sure makes one!

Bottom line: keep an eye on the drive to see that all is well, and if your drive should sleep, it does… I will bet you have a minidlna folder on drive, too.

Next, some notes about the range extenders. I told you plenty above, but I want to mention to set them up individually, and turn of first one after setup before you turn on and set up second one. It all works better and devices and you won’t get confused/ Each router can be set for both bands, with a turn-off and switch to other band before continuing. I only did both bands on one; Then decided to just set up the band I wanted. But, you can do both bands if you feel like it, of course; especially if you want to be sure both band work. But, only one band at a time will work at a time on a RE, so be sure you have switched on band you want before turning it on.

I found it easier to use the iPad browser to set things up with it, so if you have an iPad, try it. Have the RE ten or so feet from router if possible when setting it up; that made things easier, too. I have two range extenders downstairs and one running up stairs. One is for 2.4, one is for 5G, and one is for 5G_EXT as I may have mentioned earlier.

MODEM comments,
Yes the new model Motorola in waiting is an upgrade for the previous model of Motorola. currently in use now, And Yes, I also have Comcast. I went with the Blast wireless service that costs about $10 more/month, and worth it. I have 100Mbps download speeds and 12 Mbps upload. I usually get those speeds, or better. (122Mbps sometimes) Sure wish upload speed was higher, tho.

Continue to let me know how it is going with this new gear. I’ll do same.

1 Like

I setup the range extenders as you suggested (one at a time) and now have one dedicated for 5GHz and the other for 2.4 GHz. They were easy to set up and both came with the latest version of firmware (no need to upgrade). One did come with the power switch button missing but I was able to power cycle the unit using a Q-tip with the end cut off. I don’t plan on ever turning them off so no big deal.

I filled out my Asus RT-N66W rebate form tonight and plan to mail it in Wednesday.

I’m on the basic Comcast cable/internet plan but on Speedtest.net I get 88 Mbps download and 6 Mbps upload speeds.

I’m jealous of my son who lives in Plano, Texas and his house has options for two different fiber optic providers! Fiber optic internet = blazing fast download and upload speeds. (Unfortunately, I have no fiber optic available where I live.)

I’m still debating the MyNet N900 router w/ 2 TB internal drive. I think my grandson might like the idea of a wide selection of movies on his tablet for his ride from Plano to my house.

BTW, I found that my RT-N66W came with firmware version 3.0.0.4.376 (It was on the UPC label.)

Missing power button: maybe it fell off and is still in the box? I would contact the seller and let them know so they can send you an exchange; I would. I find I turn mine off more that I would have thought. Sometimes the LEDs strength get lower, and a reboot helps. Hope they help you out.

I checked the FW on my label; it says same thing, also the date of MFG is 2014 (the date on my original router says 2012. BTW, the FW I am currently running is version. 3.0.0.4.376_2524 (the last 4 numbers change with each incremental version.) I need to get my rebate form in, too!

Your Comcast is likely the basic speed (50 down/ 6 UP) and my one-notch upgrade is 100 down/ 12 UP. I was told by Comcast tech that the fiber is a block away on the main road; it’s basic cable from it within the neighborhood and to the house. Whatever. When I had the 50mbps, I got around 80 or so, too, with speedtest.

Where did you find the MyNet N900 router w/ 2 TB internal drive to buy? I found my 1TB at eBay as a new, open box for $50 w/shipping, so I got it last month. Works fine, but still need to update the FW.

Thanks again on the tip on the RT-N66W.

BTW, have you installed and tried the Asus AiCloud app yet?

The My Net N900 2Tb was on new eBay for about $68. I do have the basic Comcast internet (50dn/6up). When i got rid of the old modem I had rented from them and bought the Mororola, my speeds and reliability increased. I’m not certain why I sometimes get better speeds than the 50 dn / 6 up but I like it when I do and that never happened with their old modem.

You are correct on the firmware. I guess I don’t know which version of the 376 branch the RT-N66W was running when I bought it. I uploaded and am running Merlin’s 380.58 firmware now and I like it for the few extra features it provides.
I haven’t tried the AiCloud yet but intend to do so in the future. Currently, I am trying to get all of the data off my very old Windows Home Server so I can eventually shut that power hogging desktop down. The neighbors hate it when their lights dim when I turn it on. :wink:

I will say that, although it is now outdated, for a free software that came with ten licenses for backing up PCs, it worked flawlessly and still does to this day (even with my Windows 10 PCs). I wish Western Digital’s backup software worked as reliably as Windows Home Server did.

So, you are trying Merlin’s Asus FW hack, eh? So how is it? He is the guy I mentioned way up in this thread. I could not remember his name and I said it was something like Wizard, so I was close!

I considered it early on, but when some of his features started showing up in the Asus FW with a tip of the hat to Merlin, I figured they were taking some of his best work and incorporating it into the official FW, so why be a beta tester for Merlin. You sure didn’t stick with the Asus FW very long again! Let me know how you like Merlin’s version.

Based upon the conversation we have been having here, I want to pass on this thread I have been involved with. Short story is I was helping a guy figure out why movies played on his WDTV were freezing. HE eventually figured out how to make a range extender work “in reverse” to input the 5G signal into the WIRED input of the WDTV! It blew me away what he did.

Mike

So somehow he changed the Range Extender into a Media Bridge. I wonder what he had to set in the firmware to do that?

Seems so, but I did it after reading his post using my 5G extender currently in operation, and I did nothing to it via Dashboard. All I did was remove the network cable into my laptop next to extender, and connect another Ethernet cable between my PC and Ethernet port of the WD extender.

So, yea, the WD range extender we have is also a bridge, although I do not recall reading anywhere in the user manual that it can be anything else other than an AP. I will have to check the manual to see if a bridge capability is suggested.

FOUND IT: On page 3 of the user manual under “Features” it says it is also a bridge:

“Bridge capability—Supports one wired client while in wireless extender mode”.

Probably any range extender that has an Ethernet port (so it can be an AP as ours is) also can be a one port bridge, too.

WD also made an AC wireless bridge that could be used with their AC model My Net router (or any AC router). Since neither of us recently bought an AC version Asus router, do you think (because AC is just 5G with a tweak) that the bridge would work with 5G routers, too? Seems it should still work for 5G only; same band and same frequency. I could likely use this, so I might take a chance and get it, but will look for a better price if I can find one.

Here is the link to the WD Bridge product at Grassroots Computer sale site, so take a look and let me know what you think:

It should work with our Asus RT-N66 router:

"To enjoy next-generation AC Wi-Fi speeds you must pair this bridge with an AC Wi-Fi router, like a My Net AC HD Dual-Band Router or other brands. The My Net AC Bridge is also compatible with all Dual-Band routers but will only produce speeds as fast as the router you have on your network

$50 is still sorta high priced for my taste.

BTW, how did you get data on your USB hard drive attached to your router? I can’t seem to be able to do it through my network. I have to unmount it from the router and then take it to a PC, plug it in, transfer the data to it, unplug it from the PC and then re-mount it on the router.