WDTV Media Player - video playback freezes

Recently purchased a WD TV Media Player which I use for playback of video files stored on MyCloud NAS on same wireless network. I have the latest firmware installed (1.03.07) and the Media Player finds all the files I have stored on MyCloud. These are in a variety of file formats (AVI,DIVX, MKV, MP4 etc) and all seem to play well most of the time.

However the video playback sometimes freezes after a few minutes or may not even start file playback when first selected. When this happens, whatever video file I then select (including ones I have successfully watched before) will not play (I just get a rotating orange arrow on a black screen). I can still use the Media Player to access YouTube and navigate round the media library, look at pictures etc, but no video playback at all. The only way to resolve is to power off the Media Player and reboot.

Any suggestions?

Streaming videos need a strong Wi-Fi signal from your router, and use 5G signal if you have a router that is dual-band. You may need a newer/better router, too.

When you play the same files from a usb-stick attached to the WDTV, does it work?

Thanks for suggestion. I have a DLink 850L router which according to the box is 802.11a/b/g/n/ac 2.4GHz & 5GHz WiFi.

Currently connected to 2.4GHz signal, and getting on average 62 Mbps signal strength at the Media Player location. Just checked the 5G signal and this is avergeing 248 Mbps. Will try connecting to the 5G and see if that removes the issue.

Once the playback has frozen, can’t play any video files whether over wifi or from a USB until after rebooting.

I haven’t played files from a USB immediately after startup of the Media Player, but will have a go at doing so and see if the problem occurs or not.

Always use 5G for wireless streaming of video; it was developed for that purpose. I don’t even use 2,4G unless that is all a certain device can use. Otherwise, all my devices are either wired or connect to 5G. I configure devices I do not want to use 2.4G, to “forget that network” so they don’t ever connect to it.

1 Like

For some reason the WDTVMP doesn’t find the 5G network SSID (whether operating on ‘n’ band only or ‘n + ac’), though it is visible (and connectable) on all my other devices. Will have to investigate further why this is.

My mistake. The WDTV does not have 5G capability. My unit is hard wired to the network, and that is the best way to use the WDTV if one can.

I would say your problem is likely a relatively weak wireless signal at the WDTV (caused mostly by the distance between the router and the WDTV. Your 2.4G also could be on a crowded channel, and you can change that.

If you have an Android phone or tablet, install the free and excellent Wi-Fi Analyzer app to examine your Wi-Fi signal, others around you, and indicate if you should be on another Wi-Fi channel.

Ah - I see. Hard wire will not be possible, though ‘powerline’ connection is a possibility. Thanks for the suggestion on optimisation - will have a look and look at improving the 2.4G stability to see if this resolves the problem.

Have now connected the Media Player through wired connection into a wireless extender which is wirelessly connected to the router through on 5G alone and this seems to have fixed the problem with no freezes happening in the last couple of days use. (Just as a note, I had to experiment a little with the settings on the wifi extender such that I am using only 5G to connect to the router and have turned off serving 5G from the extender. Without doing this, then the freezing still happened).

Thanks for the help on this issue!

David, thanks for passing this info on. When I read it, I scratched my head and though, nah, he didn’t say that, read it again, and again, and came to the conclusion you did write what bewildered me, and I finally “got it”. So, just to be sure I understood you correctly:

You set up a range extender to receive 5G from router and extend the 5G range, You then tapped out of the Ethernet jack of the extender and plugged other end of Ethernet cord into the WDTV’s wired Ethernet port. In other words, you are using the range extender “backwards” by turning wireless into wired output. Ingenious, and it all makes sense. Actually, that Ethernet port in the back of the extender is an INPUT to turn the extender into an Access Point, and I have used one that way to transmit 5G wireless from a network switch or back of router when at another location. So, the input can also be an output under these certain conditions.

So, near my laptop desk is a working 5G range extender to extend the signal further into the house. So, to test your method, I plugged an Ethernet cable into the extender, and other end into my laptop port that is kept wired to my network. (I don’t use wireless of the laptop at desk), and I could go all around the internet, I ran speedtest.net and got the same 100+Mbps speed as I do with the wired connection! Excellent.

Here is what else you can do. You can turn that one “wired” output into many by just plugging it into a network switch. Your WDTV and any other devices can all be “wired” this way through the switch. I have lots of network switches in my network. In fact, one of my range extenders is wired to a switch. (I have a few range extenders in operation, too).

So, thanks for teaching me something about this, too!


Mike - to be honest it was just something I stumbled on and figured it was worth a try - luckily it worked! Wife is happy too as no wires trailing across the room.



You stumbled upon it, because most people “know” it is an input connection port and would not even think of it being otherwise, but you found it can be an output, too, if “driven in reverse”. Lots of great discoveries were initially stumbled upon. After I gave it some thought, I just felt, “Yea, it makes sense.”

I imagine your WDTV is now running perfectly since it is as good as being wired. It also proves what I have said about this, and other WD devices that only run on 2.4G; that the darn things should have been designed for dual-band operation!