Disappointed with the unit: plays almost no mp4

trilogico wrote:



I apologize for my anger but I think it is logical. When we spend money on something we want to work

Hey, man, we’ve all been there.  No problem.

I just got the wdtv media player, I wanted to play all my videos that I have stored on wd my cloud but it is not working. WD support had me shut down, restart, and rebuild and nothing that they have suggested worked. I am currently using firmare WDMyCloud v04.01.00-408 : Core F/W … The WDTV will play some of my videos but not all of them. Seems to play only 25% of my mp4 files. Can anyone tell me what to do??? Thank you, I am very frustrated with WD!!!

godslight wrote:
Can anyone tell me what to do??? Thank you, I am very frustrated with WD!!!

Roll back, as suggested countless times in this very thread.

Unfrotunately,  the Non Playable MP4’s i have       (Most play, but some don’t)

Won’t play on on WDTV Media Player (Personal Edition) Firmwares …




The same MP4’s play fine on my Live Hub (2.07.17) and on my older Live and even my Gen1.

For WDTV Live Streaming (SMP) users … the solution is to Rollback to 2.01.86

Unfortunately, all the Firmware’s ive tested above for the WDTV (PE) … yield the same problem

The only “Fix” is to Re-Mux the MP4’s (to either MKV or MP4) … and then they play fine.


For Re-muxing mp4 > mp4 : http://www.videohelp.com/tools/My-MP4Box-GUI

For Re-musing mp4 > mkv : (mkvtoolnix / mkvmerge)  http://www.videohelp.com/tools/MKVtoolnix

Yup, since godslight posted the same thing to both forums, I forgot which forum I was in… :slight_smile:

connect the unit to the internet… and try to play the files    works better


I am connected to the internet. I am using WD TV media player, latest version of firmare. I am connected via brighthouse lightening wireless modem and connected to WD my cloud.

AVIs seem to play, some mp4s play but not most of them.

The forum about the media player live, which was the previous model, people are posting that they were able to get that one to play all their movies if they used an older version firmware. IF this is correct I’m taking this one back to the store and getting the older model.

I cannot get this model to play 75% of my movies.

So either wait for the firmware update fixing this or remux your files that won’t play.

could you please share the link for the file that doesntr play?

mega.co.nz is a good hoster ium curious because i dont have problems with the wd tv 

i would like to see the error on my unit

David, can you send me a private message and i’ll send you the link

Although other partner of this forum has already said it is in talks with WD say that myself. I have sent several files that will not play mp4 files. WD has also contacted me by phone to ask if the device does not play or is connected to and the like questions.

They say that next Tuesday will return to contact.

I will continue to report

thank you trilogico, i was starting to think that no one believed me, or they blamed me for these files not working. One thing that I do not understand, it clearly says on the box that the device will play mp4s. As a consumer, mp4s mean mp4s… when i iwas  talking to wd, i get well mp4 are like containers and not all containers are compatible… welll if this is the case arent  they committing marketing fraud by saying that this product will play mp4 when clearly it doesnt???

Fraud, yeah right. The WDTV does play MP4s, there’s simply a bug in 2.20.32 which due to the apparent same code base seems to have made the jump to the WDTV as well. The next update should fix this.

I am very disappointed with WD palyer, it doesn’t play MP4 and MKV  files. Why they don’t have an update for this issue since lot of people having trouble. I called tech support , they have no idea to resolve this issue.

Sam5002 wrote:

I am very disappointed with WD palyer, it doesn’t play MP4 and MKV  files. Why they don’t have an update for this issue since lot of people having trouble. I called tech support , they have no idea to resolve this issue.

MP4, yeah, it’s broken.   MKV?   I don’t think so. 

Start your own thread with specifics such as mediainfo.

Dear Forum Members

This thread, along with “Firmware 2.02.32 Not playing all mp4 files” makes very grim reading simply because I was on the verge of buying  WD TV Media Player in order to play all my NAS stored videos.  However, due to this firmware bug (contained within update 2.02.32) it now makes it impossible to purchase a device that says it will play all your stored files then to find out that it cannot play between 25 - 40% of them, and what is worse, whereas it could before.

You see, I was looking for something that could play my files on my Samsung TV without the need for transcoding, as my NAS does not support that facility.  The  WD TV Media Player came to my attention via Amazon and YouTube as the Media Player that could play any file thrown at it.

Now I find out that WD in their haste has gone and crippled the facility that raised their Media Player head and shoulders above the competition.

I just hope that WD get their act together, fix the stupid bug they introduced and return the  WD TV Media Player into a product that people will want to buy again.

UK Bob

You guys are cracking me up. Contrary to most players out there the WDTV does play most of the files (where does it say all?) out there (crappy downloads from the Internet notwithstanding). So yeah, WD botched it and some types of MP4s are no longer playable (it’s a container, you know). A lot of em still are and it’s really not hard to downgrade to 2.01.86 to play all your precious MP4s till the next firmware fixes this.

Hi Bob

After  had purchased my wd my cloud i wanted to find a tv to play it on, which is when i was told i had to buy a wd tv to play files. if you have a seagate, the samsung tv should work well for that, after i spent all this money i was kicking myself for not going that route…

What I have been told so far from support concerning problems w/ mp4 files is that the ones I uploaded are 24 fps and the unit is not capable to manage that. I was suggested to recode the files to somewhat lower than 24, which I have not tried yet.

I also uploaded a mkv file not working but got no info about that.

In my house, the unit stands still.

I’ll keep posting news.

**bleep**? Could you please point those [Deleted] to  this thread where MP4s with 23.976 fps were uploaded that do not work on 2.02.32 (but do on 2.01.86)? So no, it’s not because of 24 FPS. Unbelievable.