Device wont play

After owning the device for roughly a few weeks now and everything playing smoothly and fine through a external hard drive I started to run into problems. Once I play a movie it has no sound but plays fine, however if I rewind or fast forward it hitch’s and freezes up as it does then freezes up when I press play and have to hit back to return to previous screen. To make it worse it also makes every other file that worked just fine before stop working period.

I updated the firmware to the latest version through the device what made no difference so I tried the manual reset button on the device and then let it go without power as I read about that could help while I read through the problems before I bought the device but again it wont play any file at all now no matter if I let it sit, reset or try any file type

If the device does not play any file, no matter the extension, even after you reset or power down the WD TV,  then you might have a bad device.

Have you try another drive or a thumbdrive?

Yes I have but it started playing other files fine after a few hours again expect for mp4s that still wont play not sure what is wrong with it or if it’s slowly dieing? I am not good at these things

Please post the full TEXT output of MEDIAINFO for such a file.