Delete Public Share Folder or Restrict Access

Hello, currently there is no option to remove the Public folder. You can make the suggestion in the ideas boards. 

http://community.wd.com/t5/Personal-Cloud-Ideas/idb-p/cloud_idea

I cannot check right now but can they at least be made readonly?

All options for Public folder share are disabled regarding access - looks like it can only be wide open to all users.

How and why would a product like this be implemented and delivered in such a state?  USB devices attached to the NAS apparently are also public with full read/write access.  Did anyone do ANY use cases at WD?   I expect this type of stuff from the myriad of unknown companies out there putting craopla on the market every day, but WD?  WD still demands a premium for their products based on reputation and name recognition but then decides to deliver an unfinished, basically a defective product, to market.

It would be nice to receive some comments from someone at WD.

Is there any firmware update to fix this?

This is a major security issue for such a product. And not being able to restrict access and use of the Public folder is not acceptable.

I have my public folders all empty but they are open for anyone to fill them up with anything possibliy leading to running out of space on the given volumes.

Hope that the next firmware update will at least have some type of fix for this issue as well.

Unfortunately, this being a user to user forum, no official word from WD would be available regarding this or any other problem on these forums.

Even talking to the WD support, they would just reiterate the same - functionality that is currently available (or not available).

To me, this looks like a needed fix rather than a suggestion for future enhancement from WD.

adetti wrote:

I just purchased the EX4 and I am new to this machine. So far very impressed with it.

 

However I would like to totally remove the Public folder. Why is this forbidden?

 

If I leave the Public folder as is, everyone in my network sees it and is able to use it to copy anything they want to it without any restrictions.

 

I find that a little surprising that it cannot be deleted or set to private.

 

What am I missing?

 

Thanks for any help.

Hi guys, you can post the suggestion in the ideas board so other users can vote. The development team is aware of the most popular requests. 

http://community.wd.com/t5/Personal-Cloud-Ideas/idb-p/cloud_idea

1 Like

I’ve reported this security flaw of WD My Cloud EX4 at

http://community.wd.com/t5/Personal-Cloud-Ideas/Delete-Public-Share-Folder-or-Restrict-Access/idi-p/702110

Please vote (by clicking the up arrow *over there* not here). I hope that the development team will be aware of the severity of the problem.  Thanks.

If you are the DIY type, you can try this until WD fixes this (works for EX2…probably will work for EX4) ->  http://community.wd.com/t5/WD-My-Cloud-EX2/Hacks-to-make-Public-share-and-USB-shares-private/m-p/728740

BTW, please vote on my similar idea but for USB shares ->  http://community.wd.com/t5/Personal-Cloud-Ideas/EX2-USB-shares-need-configurable-permissions-configurable-ftp/idi-p/712500

I need more votes to have get WD to look into implementing the changes requested. For now I have devised my own simple hack (see thread in my post immediately above) but would prefer to see this in the firmware for all.

Totally agree. I also want to delete the share. Why is it forbidden - this is absurd.

Totally agree too!

I bought this NAS (with two WD Red NAS 4TB at the moment) (more than 620€!) last saturday and I like this NAS, but have absurd things that I’m thinking return the WD Cloud EX4 and buy a RAID/JBOD PCI controller for my one of PCs with UBUNTU.

Lords of WD, why is forbidden this option? Do you will add more options for delete, disable share folders… in the next firmware? or I must return this NAS?

Best regards.

EDIT: I didn’t see the suggestion in the ideas boards, and I created it: http://community.wd.com/t5/Personal-Cloud-Ideas/Delete-Public-Share-Folder-or-Restrict-Access/idi-p/757166

I wrote something in the My Cloud forum

http://community.wd.com/t5/WD-My-Cloud/BE-CAREFUL-PUBLIC-FOLDER-amp-PHOTOS/m-p/756544#M16621

If it works properly it should restruct access to Public to the owner/admin and any other user should be denied access to Public.

Done the same thing for the My Book Live andMy Book Live Duo, but the procedure between the My Book and the My Cloud has changed. I’ve been trying to keep the Public folder in place, but altewr the permissions at the file system level so the only users that have access is the the owner/admin and root. This is not to break anything else.

You tweak at your own risk. Let me know how you get on.

The process for the My Cloud, if correctly followed, is reversable as I’ve done it in away where you copy the permissions set on Public at the factory, you create an additional share with the desired permisions and then you copy the ACL of that directory over the ACLs in and in the Public directory.

I agree that having the Public share should be a choice.

i will pass along to the team ( the developers)

i want this implemented

i ony use public folder but this is a good sugestion

I’ve tried. At least if there Must be a Public folder, offer to either have it open or be exclusive to the admin/owner account.

It can’t be that hard to implement? I’ve managed to do it on the My Book Live, My Book Duo and I believe on the My Cloud NAS, which now has a diferent implementation of file system security.

On all the NASs all it needs is one simple option . . .

Restrict Public to owner/admin?   YES/NO

It’s not rocket science.  :robotfrustrated:

Well…  After the ACL tweak, created a new user. FTPed to the My Cloud and tried to cd to the Public folder and was denied access.  Result!  :stuck_out_tongue:

Somewhat related to this discussion is, WDphotos app can only upload to the Public folder.  Is there a place to vote for WDphotos to be able to upload to a private folder like the WDCloud app can?

My goal was to eliminate the Public drive altogether.  What worked for me on the EX4 is to SSH into the EX4

cd /mnt/HD/HD_a2

chmod 0444 Public

After a reboot of the EX4, I confirmed that access to Public was indeed blocked.

It doesn’t get rid of the Public folder, but just disables access to it.  Hopefully the EX4 won’t reset this.

Still no fix…??

03-12-2014… Was the first post regarding the Public folder deleting.

21-08-2015… and till no fix/solution is given in order to delete/get rid of the Public folder.

WD Please treat your clients correctly in order to continue to buy your products.

Hope someone will read my post 

Hi,

I found a quick fix for this, by simply renaming/hidding the Public folder.

  1. SSH to the WDMyCloud
  2. cd DataVolumes/shares
  3. mv Public .Public

Worked for me.