D-Link DWA-125 works

Just to keep people informed that the D-Link DWA125 works well with the WD Media Hub. This adapter shows H/W Ver A2 and F/W ver 1.30

Hope it helps.



I guess that would make sense, because that adapter is listed on the Compatibility List…


Yes indeed, but I found that so many had doubts about this; specifically could be the version issue…I bought this on ebay 2 days ago and before i did that i couldn’t find a straight forward answer as to whether this particular one worked. So that’s why I thought I must tell it to others interested.

I too have been looking at this USB adapter.

According to this site: http://wikidevi.com/wiki/D-Link_DWA-125_rev_A1

Revisions A1 and A2 are both based on the same Ralink RT3070 chip.

Revisions A3 and B1 are both based on Ralink RT5370.

According to the information provided by darrelj we can safely assume WD TV Live Hub supports Ralink RT3070.

Hopefully I’ll be able to find one of these 2 revisions at the store.

It’s a hassle trying to find an adapter for this media player online since online stores don’t provide revision information and returns are not easy.

I suspect multiple Ralink based devices are supported. For example the Asus USB-N13 revision A1 was based on a Ralink (I was unable to find any info on the version 1.10 listed on the WD supported device list).

However the newer Asus N13s are based on a Realtek chip so I would not bet on those since I haven’t seen any Realteks anywhere on that support list.

I found this site: http://wikidevi.com/wiki/ to be useful in finding out information about different revisions of devices and the chipsets they come with.

Good luck to you all, I will post again if I find any useful information, I will try to get my hands on a Dlink DWA-125 which I saw at the store today, however I don’t remember the revision number.

I have bought and tried a D-Link DWA-125 rev A3.

This device does NOT work with WD TV Live Hub firmware 3.08.14.

This probably means this version of the firmware does not suppor the Ralink RT5370 chip.

Slightly old, but yes I can also confirm that the DWA-125 A3 does not work.  It is frustrating since the packing only specifies DWA-125 and it is not easy to return something especially if the device is really working.

I really hope that WD will include this device in a future firmware upgrade since finding the older devices that’s on the approved list is not easy.