Content scan never finishes

It’s such a shame that what could have been a great product is plagued with problems and should have never been released until these are fixed in the firmware.

Besides frequent network disconnects which require reboots and make it highly unreliable both in the home network and as a cloud, MyCloud 3TB never ever finishes the content scan. It seems to be stuck at the last 700 or so images every single time. Rebuilding the content database never helps and never actually finishes. I also suspect this process is not letting the device go to sleep.

It’s difficult not to regret buying this product now… :-/


Same problem with my new 4to unit. Photo scan always stuck around 90%.

I have the same problem. The Hard Drive never stop the searching for 3 days.

I contact the support.

I solved my problem …
The difference is from the photo analysis process. This process cannot process some of the photo files.
I looked at the wdmcserver.log file in /var/log and identified the directories (files) which produced the error. After deleting all the unprocessed photo files and started a rebuild process , the scan is finished. Now every item in content scan status shows a checkmark…

What was the error you saw in the log?

 This is what I saw in my log:

 Unable to extract cover art from:…-2/GEsdsd.MOV


I am having the same problem, where / how do I access the log?

The log file was wrapped, i had to recreate the problem…

The error is “Error   IMConvert failed for '/shares…” naming the individual file which is a JPG.

This error is in  /var/log/wdmcserver.log  file.

The file that caused error was a 1 KB JPG file. I had something like 170 of them.Windows also was unable to open them. I deleted those files because they were not important for me.

It was interesting to see that when I tried to recreate the problem , the first 49 files  didnot cause any problem in the dashboard (ie all items in the content scan had a green checkmark). Only after copying the 50th file i got the uncomplete bar …

Most probably the problem is caused by the size of the file , or the extension JPG being wrong.

You have to enable ssh, and logon to mycloud with root userid and password to see the logs…

It took me a couple of reboots to be able to go through the first picture scanning process.

Yes I have just discovered that the MyCloud is off converting transcoding (AND WASTING SPACE) ALL my images.

It seems to create a HIDDEN folder “.wdmc” in EVERY folder that has  images.


The Samba config is setup to HIDE the “.wdmc” directory via the veto file.

I saw a CONVERT process running and discovered this.

WDMyCloud:/shares/pcdrive/pics/2006-06-16/.wdmc/transcoded_files/d312a08daf7d4218a7d1222eb67d1906# cd …
WDMyCloud:/shares/pcdrive/pics/2006-06-16/.wdmc/transcoded_files# du -sh *
46M d312a08daf7d4218a7d1222eb67d1906
WDMyCloud:/shares/pcdrive/pics/2006-06-16/.wdmc/transcoded_files# ps -ef| grep convert
root 2395 6540 99 16:33 ? 00:00:01 convert -size 1024x -define jpeg:size=1024x1024 /shares/pcdrive/pics/2011-07-24/IMG_1142.JPG -auto-orient -background #000000 -quality 85 -gravity center -filter box -interlace plane -resize 1024x1024> /shares/pcdrive/pics/2011-07-24/.wdmc/transcoded_files/d312a08daf7d4218a7d1222eb

I NEED TO SHUT THIS OFF… and I guess go clean all these .wdmc dirs… ugh

Only 653 of these .wdmc dirs to NUKE… argh

WDMyCloud:/shares# find . -name .wdmc -print |wc -l

AND wasting about 1.7GB so far…

WDMyCloud:/shares# find . -name .wdmc |perl -lne ‘print quotemeta’ |xargs du -sk|awk ‘{sum+=$1} END {print sum}’

All to confuzing, I think I will just leave it, hopefully WD fix this problem in a firmware update.

Just out of intrest, my content scan status on the UI landing page displays “Idle” but photo scan percent is stuck on 98%… shouldnt the status be “Scanning” if it hasnt finihed?

Also would the unfnished scanning of photos prevent the WD My Cloud from “sleeping” I havent really checked if the unit is sleeping when not in use but just now I have checked and the HDD seems to be spinning and the LED on the back of the unit is flashing as if it is reading data etc.

It looks like the drive app is creating thumbnails and reduced size version of the original pictures. When you access a picture through WD Photos you see the reduced size version, but you can access the “HD” version.

Did you discover how to stop the My Cloud from creating these .wdmc folders and thier contents?  I’ve turned off media server and deleted all of the .wdmc folders, but they’re reappearing.  Do I need to disable something else (or perhaps reboot after disabling “media server”)?  Grrr. :slight_smile:



I basically turned off all “Media Serving” from shares also from command line ran: 

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

I no longer get  the .wdmc directories.

That is correct. You need to do the following:

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

1 Like

Thanks for sharing this information. It’s pretty upsetting that the box doesn’t honor the user settings. I had the media-server functionality turned off for all shares as well as globally in the settings, and yet there were hundreds of .wdmc directories filled with junk. It created jpeg files in my music library for each mp3 file … what the heck? On top of that, WD support never followed up on any of the service requests I issued. Did somebody get a response from anybody at WD?

From the latest firmware, there was an issue with mov/mp4 files that made the My Cloud hang. Seems twonky might have issues if the media file is bad

Sigh. From the release notes, it doesn’t seem that any of the problems I am seeing have been addressed. Here’s to hoping that there will be future fixes. It’s a good product, but the software could be a lot better.

1 Like

Never really used SSH much, how do I actually open the log file to see what file is causing the error? Do I need to copy the file to another directory on the My Cloud?

any solution guys…mycloud has been scanning for days (same number of videos, music…eyc) looks to be stucked