Complete Drive Test - Failed

When running WD Drive Utilities - Complete Drive Test, I get a message that the test Failed. What does this mean and what should I (or could I) do about it? This is with a My Passport for Mac, using Apple OS 10.12 (Sierra).

It means your hard drive is not healthy and should be replaced. You can request a free replacement under warranty in the following link:

Running Sierra 10.12 with a new 3TB My Book for Mac on a late 2015 iMac. This is my second new 3TB WD drive. The first gave issues accessing folders under Time Machine and failed a Complete Drive Test. So returned it for a second. I have not yet tried with Time Machine but this one also fails the Complete Drive Test with same message “Complete Drive Test failed” . Based on a few messages here I’m wondering if this is a Sierra and WD issue? Seems unlikely I would get two faulty drives in a row.
Interestingly, I have an older 2TB MyBook which is working perfectly on TM.
Any thoughts from WD or should I return a second drive?

I recommend you email WD support for assistance with this issue.

https://support.wdc.com/support/case.aspx?lang=en

Update on this drive. I have run a full surface scan on the drive using Tech Tools Pro 9 which is now fully Sierra compatible and the drive passes with no bad sectors and a clean bill of health. I am away for a few days but will then proceed to set up for TM and report on result. After that, if there are errors I will contact WD as I’m beginning to think this is a Sierra issue.

Rossh51: I would say that perhaps its a drive issue. I’m still running El Cap and have a new 4TB My Passport that originally failed formatting when I first got it but after multiple attempts, was able to get it to format. However, I’m unable to copy large files over to the drive. I have a 3TB that I’m currently using and works great but looking to retire soon due to heavy use which is why I got the 4TB. I personally think its a drive issue and not an issue with Mac.

Update on this drive. It is performing flawlessly for three days now on Time Machine which supports the Tech Tools Pro diagnostic result. Don’t know why it failed the Complete Drive Test.( Note: the “put hard disks to sleep” setting was not checked during this test.) Clearly also the drive I returned was faulty as that did not work on TM.
I have to wonder about the WD diagnostic and Sierra based on posts here. And, if problems develop I will post again.

After this last post I thought it would be worth running another complete drive test. The drive now passes. Go figure!
Hopefully I am in the clear.

Issues have returned. Drive still passes all tests.
Issue appears to relate to the iMac sleeping. If I prevent sleep then the TM backups work fine and continue indefinitely. Allowing the iMac to sleep results in a backup failure and a “locked” drive which must be forcibly ejected.
Like others here reporting issues with TM I am running OSX Sierra. There seems to be an issue.

This sleep failure is occurring on both USB 2 and 3.

Rossh51,

Please note that this is a user to user community, not a direct support venue. If you would like to get a direct answer from WD reps, please create a case on the following link.

Well…I would if the system was working. I have tried three times since this reply to raise a case (using two different browsers) and each time it appears to have worked with case number etc but no confirmation email is received (email checked and also checked Junk etc) and no response from WD! if you would like to check your end.

Further investigation shows this issue is independent of Time Machine. If the Mac and disk sleep then the drive is not accessible and frozen on wake up. Starting to wonder about disk!

I’m having exactly the same problem. No answers from WD support. Did you ever come up with a fix for this?