Closing WD My Cloud app does not logoff access -- HELP this is not very secure!

I have gone round and round now trying to set up MyCloud for mobile access…actually I was able to easily gain access to my device.  The directions are not very clear at all as far as exactly what steps to do in what order.  I initially set everything up using my PC (including setting up my password for my mobile access).  I went to the Play Store, downloaded the app, typed in the password and had access.  I never even used the email.  Then when I couldn’t logout, I remembered the email and tried to follow those directions and at first I was able to logon (then I changed something which I don’t remember) then I couldn’t logon because it kept asking for my “network password”…I typed in the network password but it kept telling me it was incorrect. 

Then, I looked at the “configure access” screen on the desktop and realized I was supposed to have done something with a code to activate the device.  It said to type it into the app…there was no place to type it into the app.  I uninstalled and reinstalled as well as deleted my access completely hoping to start all over and do it right.  Well, it made no difference.  So, here I am again, unable to log out.  I did read the previous post and your response to setup a password before you can access the app.  Either I’m not in the right place or it does’t work.  I opened the app and on the first screen possible, clicked the menu button to go to settings.  

I clicked the box for “Passcode Lock” and set a passcode.  It doesn’t change anything…I close the app and reopen it and it still opens right up to my device.  I tried going to the “manage apps” settings on the mobile device, selected the mycloud app and clicked “Force Stop”.  Then when I reopened the app, it did ask for my passcode to open the app but if I just close the app again and reopen, it DOES NOT ask for the passcode again…unless there is something else I am supposed to do to “close” the app.  Am I really going to have to remember to “force close” the app everytime I am finished using it???  Sorry if this gets answered twice – I wasn’t sure if it was better to reply to previous similar message or post a new one.

Thank you!

[MOD: Edited for easier reading]


The wey that you are describing the application, it’s how it works.

As a recommendation, add this as request to the ideas board to see if that can be implemented on feature updates.

Link to the ideas.

Disappointing, but thank you for the info…You’d think in the day and age of information compromise, etc, that would have been a no brainer…