Clean OS (Debian), OpenMediaVault and other "firmwares"

RTFM!!!
Для кого пишу, спрашивается!?

# Power off:
_shutdown -Ph 0 
# Reboot:
_shutdown -r 0

Thanks Fox_exe! DSM5 running great, managed to get Transmission running through package center too, just had to add http://packages.synocommunity.com/ as Package Sources and enabled home directories under user settings (don’t know if that matters) and just made public directory for the downloads :yum:

Didn’t try other community packages yet, they had couch potato etc. I just wish it would be possible to speed up samba a little bit. Quickly tested on small 500MB test file 30MB/s write and 80MB/s read :slight_smile:

Anyway thank you very much Fox_exe! :christmas_tree:

Hi Fox. I’m having a trouble right now…
I had a mistake with extractig a file

this is what you said,

tar xvfz Linux-3.2.68-bin.tar.gz -C /
dd if=/uImage of=/dev/sda5
rm /uImage

but I think I extracted this on -C /root by my mistake… I was very fool

so my cloud doesn’t work after rebooting…
even I press the reset button for 40s but It doesnt work.
I feel very sorry for this but what should I now?

Strange. Had to occur nothing (If you didn’t change a kernel, of course. dd gave out errors?)
Need change kernel and libs. Use Recovery package or any lnux on your PC.
Info:
https://drive.google.com/open?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE
or
http://anionix.ddns.net/WDMyCloud/

‘dd’ didn’t occur error because the working directory was /root…
Currently I took out the hard drive of my cloud. because it doesn’t boot and i can’t log on ssh. Even it doesn’t connect to the network.
I connect it to my computer, and I boot my computer with usb that has systemrescue cd which is from SystemRescue download | SourceForge.net

I’m trying to mount /dev/sda1 to specific folder to put the kernel library inside. but it keeps saying this error.
mount : /dev/sda1 is already mounted or /hd busy

Of course the /dev/sda1 isn’t mounted and /hd is not busy as well…

Do you have any idea of it??

===
Thanks for answering Fox!!

I read your reply, and I tried to dd recovery image to sda 6, sda 7 following your document.
But I still can’t connect to my device.
It shows green light, but I can’t find it in my router. It seems not booted well.

thejb, connect WDMC direct to PC and use start_DHCP scrpt and you can see what IP got WDMC (Also - easy to transfer files via tftp)

Use “mount | grep /dev/sd” to show all mount points of HDD.
Notice: /dev/sda1 = root only in DSM! In OMV/CleanDebian/Official firmware its /dev/md0 (or md127 if mdadm installed and configured to auto assemble raid’s)
mdadm -S /dev/md127
mdadm -A /dev/md0 /dev/sda1 /dev/sda2

  • where sda = WDMC HDD

Hello Fox,

I too would like to run a clean Debian or DSM on my Mirror 8TB. A few posts up you say it has different hardware. Maybe if I make some data dumps, could that work for you to check if it is compatible?

Is there an alternative to your great work for the Mirror?

Thanks, take care.

P.S. I’m new to this forum and really respect what you do! Good job!

I need hardware for testing or remote access to UART. (Need see what happend in Real console. “Blind method” not work here.)
Would be perfect if someone spoke my language (Russian).

Thanks for your reply Fox,

Would it be possible to configure a remote UART connection? My Mirror is brand new so not using it yet for file storage, so format etc. is ok. I’m familiar in routing ports through my router for direct connection.

Maybe a direct connection between a computer and the Mirror and setting up screensharing for you would be a solution? (Just thinking out of the box!)

Sorry, do not speak Russian :frowning:

The DSM is up and running for several days now. Big thanks to Fox_exe!
It is functioning so well and fast enough at least for home use. I tested the usual packages such as the photo station, file station, sync station, etc… The external access is working well too.
So far the only things that didn’t work for me are setting user quota and usb drives. Maybe it’s just user error. After all I’m not familiar with the DSM myself.
Totally good for home use and thanks again, Fox_exe.

Need kernel modules or some code, ported from DSM kernel…
I will check it later.

Hi Fox_exe awesome mod, I’ve tried the OMV and DSM reslease but couldn’y make iSCSI work… In fact in OMV I’ve managed to brick the device because I messed with the sda4 partition in order to create a logical vg. Is there a workaround to make iSCSi work? In DSM I believe the iSCSi fuctionality is not installed at all. Thank you for your efforts!

I dont need that, so i dont test it.
But i build OpenISCSI module for test (Used in OMV. For DSM need another module ot something else). Check latest kernels on G.Drive.

About recovery for dsm install. i am having problems understanding the telnet instructions… sorry

i create new original firmware and partitions on 2.5" SSD and boot fine on WDMC.
I then do “Boot Recovery from HDD” and reboot. I have green light.
but how do i telnet?? i try on mac linux and windows and get
Trying 192.168.0.3…
telnet: connect to address 192.168.0.3: Network is unreachable
telnet: Unable to connect to remote host

192-168-1-135:~ Evo$ telnet mycloud.local
mycloud.local: nodename nor servname provided, or not known

For windows - use PyTTY tool.
For linux or Mac - minicom

Hi. Thank you for the Work you have done @Fox_exe

i do all without telnet or shh. i just use linux. DSM working very well on my 2.5" SSD

my notes. always check disk and partition identifiers

Try on Spare HDD/SSD 2.5"3.5" not Main WDMC HDD

    Debian USB Instructions

    Follow step 1. for changing original WDMC HDD to DSM. Follow Step 2. for Using a New Clean HDD

    cd **/to file Path**

    dd if=boot-sdb6-recovery.env of=/dev/sdb7
    dd if=recovery of=/dev/sdb6

    Connect to WDMC reboot until green light then Power Off…

    1. Partition WD to DM5 HDD **Will Delete Original WDMC HDD** - If New HDD go Step 2. 

    Connect to Debian via USB

    **check /dev/sd* info**

    mdadm --stop /dev/md127
    mdadm --stop /dev/md0

    unmount partition 4

    mdadm --zero-superblock /dev/sdb1
    mdadm --zero-superblock /dev/sdb2

    parted /dev/sdb

    rm 1
    rm 2
    rm 3
    rm 4
    rm 5
    rm 6
    rm 7
    rm 8

    2. Clean HDD Install
parted /dev/sdb
    mkpart primary 1M 2048M
    mkpart primary 2048M 3072M
    mkpart primary 3140M -2M
    mkpart primary 3072M 3106M
    mkpart primary 3106M 3134M
    mkpart primary 3134M 3136M
    mkpart primary 3136M 3138M
    mkpart primary 3138M 3140M
    q

    mkswap /dev/sdb2
    mkfs.ext3 /dev/sdb1
    mkfs.ext3 /dev/sdb3

    mkdir /tmp/hdd1
    mkdir /tmp/hdd3
    mount /dev/sdb1 /tmp/hdd1
    mount /dev/sdb3 /tmp/hdd3
    cd /tmp/hdd3

    **edit user/group info**
    chown -R evo:root /tmp/hdd3
    chown -R evo:root /tmp/hdd1

    **edit path info**
    cd /media/sf_Storage/DSM/
    tar xvfz dsm-rootfs.tgz -C /tmp/hdd1
    dd if=dsm-kernel.img of=/dev/sdb4
    dd if=dsm-bootconfig.env of=/dev/sdb7
    cd /
    umount /tmp/hdd1
    umount /tmp/hdd3
    sync

    Connect to WDMC

    Done!

Any news on faster AFP? 20-25Mb/s seems max…

2 Likes

I am trying to make some sense out of MyCloud. Since I am running Ubuntu on my machines and WD does not seem to have a Sync client, I am left on the outside considering that this is the main purpose of my nas (sync and backups).

I do like the idea of DSM but I am concerned of the legal issues related to it so I’d prefer to use some other OS-es if possible. I did look at openmediavault but I don’t think there is a desktop client to allow file syncing. What other thing that looks promising is ownCloud which seems to provide exactly what I need.

@Fox_exe would a clean debian allow me to install ownCloud? Have you ever tested ownCloud?

Many thanks.

Hello! I just got my My Cloud, and would like to try this CFW. Unfortunately, it doesn’t seem the download links are working for Clean Debian. Is there a mirror or something else I can do?

Thank you in advance.

Google drive folder
Mirror on my WDMC

1 Like

Im totally a newbie on Linux, so i need ur help step by step.
Ive a new WDMC 2Tb and I want install OMV on it.
Ive download the autoinstall package (4 files).
Then which file I need?
I supposed the clean debian (but there are 5 files in that folder), is the clean debian english the right one?
I unpack the clean debian english, but I found a new install.sh file and 2 .img files (are the same files into autoinstall folder?)
Finally which file Ive to choose into OMV folder? (there are one .img file and 6 .gz files)

Tnx in advance for ur help.

mau----