Caviar Green WD20EARS 2TB PCB and a few other questions


#1

Hello all (my first post)!

Background: I have bought a new WD20EARS 2TB, connected to my Win 7 machine via a eSATA docking station, formatted it, and then transferred about 1.3TB worth of data to it, then one day suddenly, while the WD20EARS is powered and connected to the PC but not being accessed, win 7 frozen and upon reboot, PC can’t detect the WD20EARS and I don’t think the WD20EARS managed to power up ever since (tried 3 power source/adapters).  Now given that I just bought that drive, I took a bold guess (after reading up on the web) and quickly ordered another WD20EARS from the same online shop.  Luckily for me, they do seem to come from the same batch (manufacturing date are just a few days apart) and I have successfully swapped the PCB and retrieval some of the lost data!  :smiley:

  1. PCB related question: Now, I am wondering, if I  keep both WD20EARS (I haven’t even formatted the newer WD20EARS yet), would I be able to use the functioning PCB to access both HD in the long run?  I know that there should be something adaptive on the PCB specific to the drive.  Is the adaptiveness specific to a batch of harddisk, or would it evolve following the drive’s usage, so as the two WD20EARS age, their PCB need to store something different?  (I know it does not make sense, as I will be gambling 4TB worth of data on a already proven fragile single PCB design)

  2. PCB related question: Does just unscrewing the PCB and taking it out and put it back void any warranty? The label just said: void if seal, label or cover is removed or damaged.  My friend is telling me that they use special paint on the screws so they can detect if the screws have been worked on???

3)  PCB related question: Is there any recommendation on how not to fry the PCB again? I didn’t notice any noticeable drop in voltage/current (brightness in lightings) in the room when the first WD20EARS fried…  And my other HDs connecting via the same docking station are still healthy. And both the PC and the power source of the docking station are connected to surge protected sockets, so I don’t know what more precaution steps  I could have done :frowning:

  1. WD20EARS  performance:  My motherboard is a very old ASROCK  ALIVENF6G-DVI board (with SATA only), and I am connecting from the internal SATA socket via a SATA2eSATA panel then a eSATA cable to my SATA HD docking station (the total cable length should be less then 1.5M.  It took over 4 days to a full (non-quick)  format the first 2TB WD20EARS  under win7… is it normal?  The write speed after formatted is about 20MB/s when write cache disable and about 40MB/s with write cache enabled (can’t remember exactly now, can verify again later),  but my other SATA drives only achieve less than 70MB/S via this docking station set up anyway, so is this performance within normal parameters for WD20EARS ?

  2. Not particularly related to this WD20EARS failure, but is there any recommendation of good SMART monitor software running under Win7?

Thanks!


#2

Hello.

I am having virtually the same problem.  I bought this drive and I used it for one day, I was preparing to clear my other 1TB WD Black drives to create a raid array and copied 1.5 TB worth of my data to the new WD20EARS drive.  1 day later it is not being recognised by the bios or windows, and I have tried using a different PC and a different SATA controller on my motherboard, At this point I’m considering purchasing another one just to transfer the PCB in hopes I can retrieve my data.  Cant someone please let me know what the chances are the PCB’s from two WD20EARS are interchangable?  As much as I would love to warranty the drive, my datas worth much more to me.

This failed while connected to a Asus Sabertooth X58, and a Corsair AX850 PSU while being in use for 1 day.  The drive spins up however It is not recognised at boot in either PC. and caused the bios to hang while detecting the drive.


#3

I had a similar problem, a WD20EARS just went offline, a reboot of the PC and the machine hangs trying to detect the drive. The solution for me was to open the case, remove the drive and put it on another sata cable. It worked, then I put it back on the old one, and guess what, it works. So my suggestion would be to turn your system off for a minute or to and reconnect the drive.


#4

Just an update on the problems I was having… the reason the WD20EARS went offline was because of a bizarre conflict when using the ICH9R (or ICH7R, ICH8R) chipset with an onboard Marvell Yukon 88E8056 nic. I had to update the onboard ROM to REV4 and things started to permanently work right. All the reboots I was doing masked the problems for a while.

No matter what brand of motherboard you have you need to do the following if you have an Marvell Yukon 88E8056 onboard nic.

I can confirm that any motherboard using the onboard Marvell Yukon 88E8056 will have stability problems unless it is updated to REV 14. You’re not crazy. This is the correct fix. Download the following file and from DOS run the included eep.bat file. Enjoy the new stability.

Read install notes below:
http://www.gigabyte.com/fileupload/FAQ/2372/faq_marvell_eeprom.zip

This 88E8056 firmware update (an option ROM) will correct the following issues:
"The device, \Device\Ide\iaStor0, did not respond within the timeout period."
CDROM DVD showing up missing.
Windows “Server” service hang.
Hard disk activity light staying on.
System and hard drive hang.[/list]

Flashing the 88E8056.
0. Download the faq_marvell_eeprom.zip file.
1. Uninstall the driver using device manager in windows.
2. Boot into dos.
3. run the eep.bat file.
4. Boot into windows and install the latest Marvell Driver which is currenly 11.30.1.3 (listed as yk62x64_v11.30.1.3 at marvell.com).
5. Install the latest Intel storage driver which is currenlty 10.1.0.1008 (listed as Intel Matrix Storage Manager dated 12/15/2010). If you’re using ICH9R (ICH7R, ICH8R, etc) onboard raid you should download the RST version.
6. Optional: If you’re using SSD drives you should update the BIOS Option rom for the ICH*R series to whatever your mother can support. For the ICH9R series this is 8.9.0.1023. To do this you may need to have someone make a custom BIOS mod for you. Ask them if they can included the updated Marvell rom to help some other poor soul.

Reading on the subject:
http://vip.asus.com/forum/view.aspx?SLanguage=en-us&id=20080813182205171

I hope this helps someone. I was really wonder what happened to my stable system. Before I had just one drive hook up and this does not cause conflicts. Installing several sata devices really brings out the trouble until you update the EEPROM.