Can't get WUSB600n to work with new firmware on new unit


I have two newly purchased WD TV Live units with the latest firmware installed. Neither unit seems to accept a WUSB600n (v2)  wifi adapter. I see on the board thatpeople use the 600ns successfully which is why I bought the adapters. I’ve tried every type of reset mentioned on the boards, plus bought a second Wusb600n.  Neigher adapter works in either usb port in either device. Ideas or links, please?

from what I’ve read USB wifi adapters don’t work.

there have been posts that say Ethernet wifi adapters do work though.
if you get one you need to set it up on a computer first so it can save your network settings then it should be good to go.

The new WDTV unit is the Streaming Media Player, not the Live or Live Plus.  If you have a live or Live Plus, you are in the wrong forum., This forum is for the Streaming Media Player.

If you have a Streaming Media Player, it has built in WiFi and external USB adapters are not needed.

Thanks for your replies.

I should  have clarifiied - units are streaming media players. I  am looking for the dual band capability so that I have better signal. One unit is wired  but the other is set up wifi.  I understand that the SMP does not support 5GHz by itself. 

I have issues with some video types - mkv and mts - stuttering - no matter how I access and  set up playback.

I was hoping to improve wifi performance without having to set up a repeater.

I guess I read wrong that an SMP would take an adapter to get 5ghz capability.

 Edit: current house wiring doesn’t support powerline adapters or ethernet over coax.

Network status in SMP shows 3 bars but some delay with browsing the files  at times and delay in running some files - mostly mkvs.  Tried most ideas in the forums - run these off a NAS  with a good router. Use network shares or mediaserver shares.