Can't figure out how to remove the "WD Unlocker"


I’ve searched everywhere for an answer to my question, but no one seems to have the correct response. My “WD My Passport”, I believe, has WD Smartware on it. When I first got it I set the unlocker so that I would be prompted to unlock the drive every time I plugged it in. Big mistake. I am trying to connect the drive to a 3rd party, non-traditional computer (Like a game system), but nothing happens. I believe this is because of the unlocker blocking the systems access to the drive. I read that it can be disabled (not deleted) using the VCD Smartware manager; HOWEVER, all of those files were located ON THE DRIVE. I stupidly formatted the drive and deleted all the files on it, including the Smartware maintenance applications. I tried updating the firmware and downloading a WD VCD manager, but after I restarted and did the proper set up, the manager said “Please connect a WD Smartware drive to continue; then click Rescan”. I don’t know what to do. I know for a fact my drive is plugged in, under the name of Local Disk (F: ). All I wanted to do was to get rid of the unlocker prompt. Help please, thanks.

To be clear, can you actually access the drive on a “normal” computer with the regular drivers (and optionally smartware and the SES drivers) installed?

The “local drive” if my understanding is correct is just the drive control electronics, rather than the actual drive platter itself. I had an issue a few weeks ago with my “MyPassport” drive where it could be seen on the PC as “local drive” but couldn’t be accessed at all. After some testing the consensus was the actual drive hardware itself was knackered, and the drive got replaced as an RMA.

But if you have the drive locked, then you won’t be able to see anything on it until it’s unlocked of course (as the drive will be encrypted). And that unlocking can only be done for systems where the unlocker is supported, which may not include your games console. I had something similar accessing my MyPassport via a wifi SMB box from an Android tablet - it only worked when the encryption was turned off as of course the tablet had no way to decrypt the drive on the fly like a Windows machine can on connection via the software.

The download link for the MyPassport Ultra software is I guess you maybe want the WD Security one? If not I can have a look at what’s on my MyPassport drive and see if it can be copied off and posted somewhere for you to download if that helps.