Can't delete files from MBL on osx 10.7.2

I’m trying to delete some files on my MBL and i keep getting error code -50. i can’t find much on this error in osx and am able to force remove some files using rm -rf but some files still give me an error invalid argument and i can’t delete them.

the MBL is also very SLOW to display certain folders. other than that it seems to be working well. its just painfully slow and i can’t delete files in finder.

please help

What firmware is the MBL? And did you confirm if you can erase files from other computers that are NOT on Lion?

i don’t have a computer not running lion. i will update the firmware now. it is not the newest one.

i upgraded the firmware and still have the same error code -50.

how can i delete files from my mybook live??

is this a lion issue?

I have a slow file listing problem also on folders with a lot of files.  I blame that on the smbd implementation on the MBL.

The -50 or -36 errors sound like they are related to named streams, or appledouble files.  See here for some hints

Are you connenting via smb or afp?

i tried disabling named streams but that didn’t help any. still getting the -50 when i try to delete almost all files.

sometimes it works but most of the time it doesn’t.