Can't assign drive letter to My Book

I have a My Book Home edition (p/n WD10000H1CS) and it has worked fine up until I switched until a computer with Windows 7. It shows up under My Devices but not under My Computer. I have tried the following

-Made sure the driver was up to date.

-Tried plugging it into another Win 7 device which did show it under My computer and it was accessible

-Checked the drive using WD’s WinDLG and it passed all the tests

-Tried to assign a drive letter using Disk Management. I can see the drive but I get the error "The operation failed to complete because the Disk Management console view is not  up-to-date. Refresh the view using the refresh task. If the problem persists close the Disk Managmenet console, then restart Disk Managment or restart the computer.

After I got this error I have

-Used the Refresh button in Disk Management

-Made sure the drive was online and also turned it offline and back online

-Restarted the computer

But I’ve had no success assigning a drive.

I tried running diskpart but while drive 0 and 1 show up differently under disk management, under disk part when I go to list the volumes, the exact same volumes are listed under disk 0 and 1 which makes me suspicious and hesitant to try to reassign drive letters this way. I’ve double checked that I changed the drive before listing the volumes.

So far from web searches the answers have been to reformat the drive at this point which I’d rather not do if I can avoid it. While I can access the data using another computer, I’d like to avoid the amount of time it’s going to take to move 750+ GB of data if possible.

Is there anything else to try?

Thank you


It sounds like something is corrupt. Something like TestDisk might fix it. Personally before I tried anything I would copy the data if it is the only source before a disaster. Some people say that TeraCopy improves transfer rates.


I reformatted the drive using Disk Management and the computer still isn’t allowing a drive letter to be assigned. I’m now not sure that diskpart is picking up the My Book but I’m stuck on what to try next.