Canon Imagerunner IR ADV C250 cannot connect to PR4100 after update to OS5

Before update to OS5 (5.04.114) everything worked fine.
My PR4100 works fine, I can connect and map drives from Windows 10, Cloud funtions are all OK.
I’m using the Canon as a netowrk printer and scanner, its located within the same network as my PR4100 NAS.
Here the Network settings:
AFP on
NFS off
SNMP off
SSH off
Dynamic DNS off

Windows Services:
Workgroup is WORKGROUP
Local Masterbrowser off
SMB is SMB3 (I’ve already tried SMB1+2+3, not better)
Aggregation off
Active Directory off

By the way: Sending the CANON scans via email over the network still works fine.

Has anybody an idea whats changed betwenn OS3 and OS5?


@Jenvar NTLMv1 is not available on the current firmware version of OS 5.
Adding ntlm auth = yes to the smb.conf file can be used as a workaround for now.
Here’s the workaround posted in a Sonos thread.

Hello SBrown,
thanks for your help, I appreciate it. :+1:
It helped as a workaround and now I understand the background.
And I contacted Canon to aks for an update of their firmware to current secutity standards.

Meanwhile a Canon technician has updated the firmware so it “understands” SMB3 and it works fine with WD OS5.