Cannot rewind/FF in .m4v video files


#1

Hello everyone,

first post … :slight_smile:

I just bought a WD TV for my father so he can access his library of music and videos, which I have assembled for him on a USB harddisk. He has no computer, so whenever something goes wrong, I have to do remote assistance over the phone or ask a friend with a computer who lives near him to fix things that cannot be done from the WD TV. This makes pinpointing and solving problems a bit harder.

So far, most features work. However, I encountered a problem with some video files: Fast forwarding and rewinding in .m4v videos is not possible (playback and stop works fine, but pressing the RW or FF key brings up the “forbidden” icon in the upper right corner). These are videos exported from iMovie 09 on a Mac.

The file extension used for these files is “.m4v” (this is the iMovie default).
The video codec is H.264.
The audio codec is AAC.
The resolution is 720 x 540 px.

Any idea why this happens or how it can be fixed?

Would it be enough to change the extension to something else; e.g. .mov, or am I missing something else here?


#2

same problem here… they way i solved it was change them to mp4… im pretty sure u can just rename then and not have to re encode… i havent tested it thogh… (mp4 is m4v so it should work)

edit:

I have now tested on first gen current firmware

and yes all you need to do is rename the file extention

to show file extensions in windows open up my documents and go to tools > folder options > view

uncheck: “Hide extentions for known file types”

then you can just rename the file: example.m4v to example.mp4

if you have a lot of files you could get a program called “file renamer” basic, its free…

             Click here to go to the site

and it can rename multiple files at once… incase u have like hundreds of these…

anyway once you do all that it will work like a charm, and best of all no neet to re encode

PS if you have windows vista or windows 7 and cant see the tools option press alt and you should beable to see it, you can also get to folder options in the control panel: control panel > folder options > view then uncheck: “Hide extentions for known file types”

PSS… also to your original post, this only works from m4v to mp4 becuase they are the same… this cannot work if you want to change the extention to anything else. Example avi to mp4 would not work, if you wanted that then you would need to re encode which would take forever… so stick to renameing to mp4 only for the m4v’s :slight_smile:


#3

random11,

Thank you for your extensive reply and testing this. As I said, I have no access to a WD TV right now, so this is really helpful.

BTW - If someone using Mac OS X encounters the same problem and needs to batch-rename a lot of files: There is an excellent tool called  " A better Finder rename". It is great for changing both file names and extensions.


#4

I would like to see WDTV officially support m4v within a future firmware release? Renaming m4v to mp4 should not have to be the necessary workaround. There are other dependencies whereby renaming m4v to mp4 will break thiings, such as xbox 360 not listing any mp4 files via windows media connect.

BTW: If the dev folks happen to be reading through this thread, here’s the mediainfo from one of my m4v files:

*** MediaInfo Mac // Plain text file report
2010-01-25 17:53:47 -0800
Information for File: TRX_OVERVIEW.m4v

General / Container Stream # 1
Total Video Streams for this File -> 1
Total Audio Streams for this File -> 1
Video Codecs Used -> AVC
Audio Codecs Used -> AAC LC
File Format -> MPEG-4
Play Time -> 1mn 15s
Total File Size -> 35.9 MiB
Total Stream BitRate -> 3 973 Kbps
Encoded with -> HandBrake 0.9.4 2009112300
Video Stream # 1
Codec (Human Name) -> AVC
Codec (FourCC) -> avc1
Codec Profile -> Main@L3.0
Frame Width -> 720 pixels
Frame Height -> 480 pixels
Frame Rate -> 29.970 fps
Total Frames -> 2268
Display Aspect Ratio -> 4/3
Video Standard -> NTSC
Scan Type -> Progressive
Colorimetry -> 4:2:0
Codec Settings (Summary) -> CABAC / 2 Ref Frames
QF (like Gordian Knot) -> 0.368
Codec Settings (CABAC) -> Yes
Video Stream Length -> 1mn 15s 708ms
Video Stream BitRate -> 3 807 Kbps
Video Stream BitRate Mode -> VBR
Bit Depth -> 24 bits
Video Stream Size -> 34.4 MiB (96%)
Video Encoder -> x264 - core 79 r1347 5ddd61b
Video Encoder (Settings) -> cabac=1 / ref=2 / deblock=1:0:0 /
analyse=0x1:0x111 / me=hex / subme=6 / psy=1 / psy_rd=1.0:0.0 /
mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 /
deadzone=21,11 / chroma_qp_offset=-2 / threads=3 / nr=0 / decimate=1 /
mbaff=0 / constrained_intra=0 / bframes=2 / b_pyramid=0 / b_adapt=1 /
b_bias=0 / direct=1 / wpredb=0 / wpredp=2 / keyint=300 / keyint_min=30 /
scenecut=40 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=20.0 /
qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Date of Original Encoding -> UTC 2010-01-19 23:16:00
Audio Stream # 1
Codec -> AAC
Codec (FourCC) -> 40
Audio Stream Length -> 1mn 15s 712ms
Audio Stream BitRate -> 162 Kbps
Audio Stream BitRate Mode -> VBR
Number of Audio Channels -> 2
Audio Channel’s Positions -> L R
Sampling Rate -> 48.0 KHz
Bit Depth -> 16 bits
Audio Stream Size -> 1.46 MiB (4%)
Date of Original Encoding -> UTC 2010-01-19 23:16:00


#5

I am using the current firmware as at 31 January.  I can’t fast forward or rewind either - using .m4v files created by Toast using 720p settings.

Changing the file name to .mp4 does NOT work for me - even though the Mac opens the file OK (it uses Quicktime’s player for .mp4).


#6

I would just sujest that u are making sure u are changing the extention… if you dont have the view known extentions on then you could be naming you files like this… “example.mp4.m4v”, other than that you could try rencoding it but if the video works im sure it can be fixed by changing the extention


#7

the rename thing, eg. .m4v to .mp4 totally works - I don’t get why, but it works!


#8

Initially this worked for me as well (changing the .m4v ext to .mp4). For some reason tonight when I tried to play an mp4 file I got the “unsupported format” dialog. Each mp4 thereafter I tried to play was met with blank screen. After cutting the power and rebooting my WDTV I still got the same result with mp4s, error msg followed by blank screens.

I don’t understand why the mp4s wouldn’t play when they worked fine before. I haven’t changed my firmware. Is there any ideas or a lower lever reboot I can try?


#9

It works because M4V is just an MP4 file with the Apple/iTunes standard file extension. They are otherwise identical codecs and containers.

One issue on Mac OS X is that you might think you’re changing a file extension, but it’s actually just appending the filename, as listed above. It looks like the file is FILE.mp4 but it’s really FILE.mp4.m4v because of the way OS X handles renaming.

I no longer have a Mac so I’m not remembering how you get around this, but it has to do with actually getting into the file information and changing the extension within there. Just typing a new extension on a file name doesn’t always work and gives the result described above.

Either way, I can confirm that M4V is just an MP4 with a different filename, and yes, the WDTV has a weird time with M4V files.

I would also suggest, for viewing on your computer, don’t use Quicktime. It’s got its own way of doing things. Download VLC media player and use it to view your MP4 files to be sure they’re working properly. It’s free, and it’s much faster and more reliable than Quicktime.

Finally, I don’t suggest encoding from within Toast. It’s a great program for working with DVD files, but if you want to encode to MP4 on your Mac, you’re MUCH better off downloading Handbrake and using it to make exactly the file you need. It’s free; Just don’t try to ask the developers for help because they’re not the friendly sort and will likely be rude and somewhat abusive if you ask a question of them in their forums.

Good luck.