Cannot replace drive in PR4100

I am hoping someone here can help me with my PR4100. I have the system set up with 4 2TB drives, all WD. A couple of days ago I noticed a red LED under one of the drives. I opened the interface to the drive in a browser, and I was told that drive 3 was bad. It also told me that I has only 450 MB left, although the total capacit should be around 6TB, and I had only 3 TB used.
So I shut down the NAS, took out the old drive and replaced it with an identical drive. I started the NAS, and it ended up with 4 red LEDs. I left it overnight to see if it needed to rebuild, but this morning it was still 4 red LEDs. I opened the interface to the NAS again, and it seems there is no data on the drive at all. It says that no volumes are found, and asks me if I want to set up RAID. It also says that the available space is 0 kB.
So, I shut the system down again and piut the old (bad) drive in again. Initially I did not see the content (but the interface showed me all the folders and indicated that RAID5 was in use, although it did not give me the option to rebuild the volume). I left it for a while, and on one occasion I saw that the volume was being rebuild, but that ended in an error (Rebuilt failed). Nevertheless, after a while the contents in the folders reappeared, as if the system was rebuilding the volume. In the end I ended up where I was before: Bad drive, no more space, and a red LED for the bad drive.
So, I tried again to change the drive. Same result; a blank NAS.

So, how do I change the drive so that I keep all the data and have a fully functioning NAS?

I haven’t seen someone describe a solution to a rebuild failure yet. You may want to consider putting a ticket in with WD. If you do figure it out, I’m sure the next person would really appreciate you posting a how-to.

Thanks. I have submitted a support ticket. I’ll post any solution here, if they can help me…