Cannot read from my WD passport

Hi;
I have used WD passport for over a year now and trusted it so much that I forgot to make a back up for that backup!. About a week ago I tried to use my passport and entered the security password (which means (I think) that the cable and the utility partition (which contains the unlock file) are both fine. The first two time I booted the WD passport I was able to see the folders and files but it took so much time to display them. In both cases I was unable to go deeper into the folders and had to unplug the passport then re-plug it again. Third time around I was not able to access the drive at all. Still the unlock program runs from the utility partition and I enter the password then nothing happens! I didn’t want to do anything about the drive before I consult with the WD support who pointed that the cable might be faulty as per one post.(http://support.wdc.com/knowledgebase/answer.aspx?ID=1296) put the cable it the original cable and have been using it since the beginning, also if it was faulty then why does it work for the utility partition? Also I used the same cable for my second WD passport Ultra and it works fine. So it is not a cable problem, nor a USB port! any one have seen this problem please let me know how to recover my data. It is my life work!

Did the drive even show up in Computer? Also, I hope you’re not just pulling the plug without safely removing the drive first. Cause, if so, you may have corrupted the drive.

Because it is another partition. If the drive’s data partition is corrupted, it would not affect the utility partition.

Look in Disk Management to see if the drive shows up there. If it does, then most likely you have data corruption. You could try data recovery software to restore the partition, but I would run our diagnostic utility first to make sure the drive is good. Otherwise, you’ll need to go to data recovery to get your data.

thank you for your reply. I followed all your points and it seems that I am facing a partition corruption. The drive does not show as My Passport but rather as G drive and keeps sniping forever. I even hear a consistent one faint click from the drive. The drive light keeps blinking but nothing is happening. The Storage Management does not recognize the drive and at a later stage displays (not responding). Also WD utility does not recognize the drive at all.
What do you think I can do next? Appreciate your help and patience.

If you checked in Disk Management, and the drive does not show up in there, then you most likely have a failed drive and will need to go to data recovery. Since I’m not sure if you meant Disk Management when you said Storage Management, I put a link to it below, so you can check for sure if the drive does or does not show up there.

You need to understand that you must always have a backup to your data, especially if it is your most important data. I have two or three backups to mine. Remember a backup is not a backup until it’s on a separate drive.

Thank you very much. Now I realize that a backup needs a backup :slight_smile: ; I found several YouTube videos on how to “physically” recover data from a failed HD. If all fails I will try to do it. That would be my last resort.
I will update you on any progress about this. I hope our chat can make a mark in HD recovery. I am very serious about it and I feel sick of losing my HD data just like that! it is supposed to be reliable and at least give me a warning when something will go wrong. The HD had no sudden drops , no physical damage, never exposed to head, magnetic fields, liquids, viruses, or even a fluctuation in power. And all of a sudden with no reason or warning, all data is lost. Anyway, thank you and I make best of your notes. If you find anything more please don’t hesitate to let me know even if it sounds silly.
Best Reg.

Hi bill
Back again…:slight_smile:
I wonder why WD doesn’t have a recovery department as they know all about their drives and have the spare parts? why don’t they make a special technical group that investigates and receive damaged or non-accessible drives and try to recover the data for a fee. It is a good profit generating center plus a way that WD could improve their products by knowing what faces the drives in the real world, add to this it will improve their image and customers’ trust in their products.
Now I gave up on the drive, I physically inspected all parts, the ext. HD seems to have no problem physically, so I suspect that the problem is in the board. I tried to find an exact working replica of the HD to use the board but could not find any in the market. I found the next model of my passport 1 TB which is the Ultra one but I am not sure it’s board would work and I don’t want to have so many variables in my theory. So I think it is good bye for my data!