Cannot Eject My Passport

I am using Win10. Apparently some ransomware hacking attacks can corrupt any attached USB etc drives, so I wish to remove the My Passport backup drive when not actively in use.
When I click the Eject My Passport, I get an error message “Windows is unable to stop the device… Close any programs using this device …”
As far as I knew, no relevant programmes were being run. I went to Task Manager and ended the 3 WD tasks listed. After this when trying to do the eject, I still get the same error message.

How do I safely remove the USB My Passport after a backup?

Since you have Windows 10 I suggest asking this, eject usb drive in windows 10, in the search box. You will get several results, such as this one.

Eject USB drive in Windows 10
Save and close all open files from the USB flash drive. Save the file or files you are working on in your USB flash drive, and then close all open files in your flash drive. Wait a minute or two for your computer to finish writing data on your flash drive. Some flash drives have light indicators.
3 Ways to Remove a Flash Drive from a Windows 10 Computer

See example images below from my computer.

A message should come up in this same area when it is safe to remove the device.

I get this issue all the time, too, and it doesn’t matter what brand the drive is. It’s a process on your computer that’s accessing the drive, and refuses to relinquish file handles even when the OS tells it to do so.

Programs such as antivirus, search indexers, etc are notorious for this.

In many cases, I have to resort to shutting down the PC to remove the drive.

Thank you. I have also resorted to closing down my PC to solve the problem. Will removing the drive in defiance of the warning cause damage?

In view of this problem, should WD provide a routine to close down its activities at the end of the backup process, as seen by Win10?

It certainly can… WD can’t provide any workaround for an OS-level shortcoming. WD can’t force another program to stop what it’s doing.

The problem does not normally occur with other USB memory devices, so the problem occurs because of the way this WD program interacts with OS. Presumably WD could monitor the processes that are started as a result of its program, then reset to their starting point them at the end.
Alternatively, or in addition, WD could negotiate with Microsoft to fix the underlying incompatibility.

1 Like

Give this a read:

… see if that helps.

I´ve seen this on many sites, and none of the answers really helped me. So I kept trying. What I did:
Look for the DISK DEVICES. UNINSTALL the device you are unable to “safely remove”. I´ve restarted the computer but I do not think it is necessary.
You are done.
I´ve plugged and ejected the drive several times. Tested it with other drive I had the same problem but was a Seagate as well. Worked fine all the times. I am using Windows 7, but it should work to other versions as well.
I´ll post it on the other sites so people can easily find this. Hope it helps more people.

1 Like

Howdy my name is Colby - I am using windows 10,

I tried updating all my drivers, checking for new drivers for this device - there were no new drivers.

So I created a system Restore point before I tried Newtonu’s method - I would encourage all users who try this method to do so just in-case.

Everyone’s system is different and it may have a different effect on your system than mine, better safe then sorry - yata yata yata…

So I uninstalled the device and… Success! I was able to safely remove the device on the first try.

Restarting the computer is a good idea, I didn’t before I disconnected the device but I did afterward just to be safe.

Thanks a bunch to Newtonu!

Try NewTonu’s method it worked for me. See my post for additional details : )

I made an account on here to specifically THANK YOU for your advice. I’ve tried everything imaginable and searched for hours on end to try to safely eject my easystore without having to restart my laptop! I eventually gave up and didn’t want to risk erasing everything on my drive again (yes AGAIN), but I felt a whim today to look for solutions and saw your comment.

THANK YOU SO MUCH. I’ve tested it a few times myself to make sure nothing was damaged and everything is perfectly fine. Thank you again so much!!!


I found an easy solution to this problem. I uninstalled the WD programs and then it was able to be ejected without any issue. I had 2 WD programs installed (WD Discovery and WD Utilities) on my Win10 laptop.

Very happy now.

So normally I’d read the solution and move on, but I’ve found something better for this problem and wanted to share it.

I’m using Windows 10 with a WD Passport and in Device Manager -> Right-click WD Drive under “Disk Drives” -> click Properties -> Policies tab, you’ll see two options:

Quick removal (default):
Disables write caching on the device and in Windows, but you can disconnect the device safely without using the Safely Remove Hardware notification icon.

Better performance:
Enables write caching in Windows, but you must use the Safely Remove Hardware notification icon to disconnect the device safely.

The default is Quick Removal in my case so I can just rip it out at will.

Hope this helps someone.


1 Like

This worked beautifully, Craig3… a simple elegant solution for my WD 2TB on a Win10 computer. Thanks you!

Thank you. Uninstalling the WD Utilities worked perfectly for me with a WD Yellow 2Tb drive. But I do have a couple of concerns.

What you lose with not having WD Utils is the Erase function. This is a concern because of the problem with the security holes in WD’s hardware encryption that have been widely reported and discussed in this forum.

A partial fix (supposedly) from WD for the security issue is to use a new version of the Security (lock drive) program after first erasing the drive. You need WD Utilities to do that, I think.

I have already erased this yellow drive and relocked it using the new WD Security program. I have several other drives to follow. But maybe all I need to do to erase them is reformat them. I think that’s what the WD Erase utility does.

I also wonder what happened to the WD utility that I used to have (on a previous PC) that would re-lock and allow removal of the drive safely. It seems to have disappeared from WD software.

I also like Craig3’s solution of turning off write caching, though I have not tried it yer.

I guess I have to correct myself doubly. First, when tried Safely Eject the next time, it did not work. Usual messages about files in use, though I couldn’t find what they were.

So then I went to the “turn off write caching” solution. Turns out I already had turned it off. The screen where you turn it on or off says if write caching is turned off you can simply remove the drive without needing to click “safely remove.” So that’s what I’m doing now.

Thanks for this information. Generate hundreds of visa credit cards from official CardGenerator.

Finally found a good solution without deleting WD Utilities. Just open it and go to settings, then from there disable sleep timer! now you can eject your drive normally.

alkha_snake…disabling the Sleep timer allowed you to do the Safe Eject (down by the clock) without getting a warning message?

  • did you disable your Apps, either thru the Task Manager, or not having them running thru uninstall?
  • or is your setting under Device Manager (that Craig3 or Randy9b said.) Mine is set to “Better Performance” and I still have the Passport Sleep set to 30min…and I can Safely Eject with no message.
  • I have an issue with Sleep…even if you tell it to Sleep after some time, I don’t really see any effects, because I believe that if there are Task Manager Apps running, Sleep will not power down the Drive like what I thought Sleep is supposed to do.

I was scared reading the suggestions, I just got my WD Passport yesterday and today apparently a program is using it so it won’t eject.
If someone else has that issue for me strangely it turned out to be Discord.
Give it a try.