BitTorrent Sync installation script

Tested with firmware version : MyBookLive 02.42.03-027
No need of pkg, optoware or apt-get so far
Default settings for ‘nice’ cpu usage, idle IO nice , download at 1000KB/s and upload at 100KB/s,   so not to abuse (too much)  of the limited resources of the NAS

* ssh to your MBL
* execute :


wget https://gist.github.com/alexsarmiento/6407826/raw/install_btsync.sh
bash install_btsync.sh


You can change the  settings using the gui  at the :8888 port  and editing  the default configuration file /DataVolume/cache/btsync/btsync.conf with nano or vim

I would sync folders in read only mode , maybe this way  the btsync might not access the hard drive that much. 

The lower the data rate,  the lower the cpu and bandwidth usage , so there is a trade off . With these settings i get up to two percent of cpu utilisation  when the software is syncing. But it takes longer to sync, so not intensive  cpu utilisation means no syncronitation of large data files. I am using it just  to sync some vimwikis and keepass databases 

I do not know if with these settings the hard drive is able to ‘sleep’ or not. 

If you have any suggestions please let me know 

I used another method for installing it:

  • download  http://btsync.s3-website-us-east-1.amazonaws.com/btsync_powerpc.tar.gz (if the link is not working find and download the Linux PowerPC version of BT Sync)
  • unzip the file downloaded in Public share (you can use with gunzip command: gunzip /shares/Public/btsync_powerpc.tar.gz , or just unzip it with 7zip or similar and then place the “btsync” file in Public share)
  • make the “btsync” binary executable: chmod +x /shares/Public/btsync
  • run the “btsync” binary with /shares/Public/./btsync
  • go to  http://MBLIP:8888/ and configure BTSync

NOTES:

  • To restart BTSYnc in case MBL is turned off or rebooted, login with putty and run again /shares/Public/./btsync

  • This method does not place a config file in /DataVolume/cache/btsync/, although most of them are available in the web gui.

this is the screenshot for the btsync running process:

Immagine senza titolo.png

what should I set here to make BTSync have a smaller footprint on MBL and let it sleep every now and then?

1 Like

Well, the script i posted automatically installs the init.d job, launching the btsync executable like this:

start-stop-daemon -N 19 -I idle  -b -o -c root -S -u root -x $DAEMON – --config $config

With the arguments -N 19 and -I idle giving it the lowest cpu and IO priority . 

The intention of this method is to not install other software. But with the webadmin you should be able to control the init script too. 

I see that you launch the btsync manually without further options, but you can control more advanced settings by editing the configuration file to limit bandwidth, encryption  and connections usage wich limits the cpu usage too.  For some reason these do not appear in the webui configuration options.

Hi Nissan.

Thanks for your script.  I ran it and I think it worked.  Only problem is when I go to mblip:8888, I get prompted to type in a username and password.

What’s the username and password?  

I tried the root welc0me, my mbl admin password, router, etc.  - nothing’s working.

username: “admin”

password: “password”

once in, you can change username and password.

THANK YOU!  To both of you.

It’s working now.

My NAS has been showing a solid green light (with occassional blink) ever since I put bittorrent sync in though.  Does that mean it’s not sleeping at all anymore?  I’m not seeing an option to change the rescan interval with the NAS the way I can with my laptop.  I’m going to be syncing between 2 remote NASes so am afraid this may be a problem.

In order to update the program when new bittorrent updates are created, do I just repeat the same process?

Sorry this is totally new for me but I’m really loving it and very much appreciate your guys’ posts.

I would not know about the update process…

as far as the “sleeping” issue, well, my MBL is months it is not sleeping anymore… there are hordes of people on bittorrent sync forum complaining about this (and not just MBL owners)…

like you, I was not able to find a way to set the “folder rescan interval”. It would be greatly appreciated if someone could explain how to do it…

Do you know how I can uninstall bittorrent sync?

Not going to do that right now but asking now for just in case since you guys seem knowledgable.  I guess an always on hard drive isn’t the end of the world.  Wish it could copy subdirectories though.

Thank you guys :smiley: for getting me up and running on my 2gb WD Live.

I have just one question, probably to nicopizza as I followed that set of instructions, I’ve got the sync running on a box at my parents.  How do I set it up to ‘autoexec’ if it has been powered down/restarted or something else happens.

I will not be able to log in to the box as I won’t have the ip address (dynamic). It would just be nice if Bittorrent sync just started as part of the boot up of the box.

Many thanks,

Marcus

forgot to write, the box is currently on my LAN so I can log in and fiddle at the moment… Just got to sync up about 500gb of data before I move it :wink:

The ‘problem’ will come once I’ve moved it off my LAN to a remote location I can’t access immediately via ip.

I believe you need a “restart on boot” comand for that… unfortunately I would not be able to write that… maybe someone could helps us out, since it would be very useful to me too…

so far I managed to restart it by just reinstalling it, even from a remote location, using OpenVPN connection.

Funny I didn’t realize it didn’t restart itself on boot.  I guess I don’t have to “uninstall” anything.  I think I will remove the old files and reinstall once they update the program/fix the drive sleeping issue.

Thanks for the reply. Hopefully someone else might be able to offer some pointers.

İ make it but :8888 not work  … Can you help me pls … :slight_smile:

" You’re about to translate http://192.168.0.100:8888/, which may redirect you to another page. Are you sure you want to continue? "   writing and stop … :frowning:

How can i work this script " start-stop-daemon -N 19 -I idle  -b -o -c root -S -u root -x $DAEMON – --config $config "

i cat get work :frowning:

Has anyone tried this on the WD My Cloud?

hi ,

i tried the Nissan script and i got this error :

WDMyCloud:/# wget https://gist.github.com/alexsarmiento/6407826/raw/install_btsync.sh
–2013-12-29 21:03:54--  https://gist.github.com/alexsarmiento/6407826/raw/install_btsync.sh
Resolving gist.github.com (gist.github.com)… 192.30.252.142
Connecting to gist.github.com (gist.github.com)|192.30.252.142|:443… connected.
ERROR: The certificate of gist.github.com' is not trusted. ERROR: The certificate ofgist.github.com’ hasn’t got a known issuer.

i tried the Nicopizza commad and when i write this command line :

  /shares/Public/./btsync

i got :

-bash: /shares/Public/./btsync: cannot execute binary file

btsync is into Public folder .

Any help ?

Thanks !

I see that you are trying to install BTSync on a WD MyCloud device… I installed it on a WD MyBook Live, and I do not have a WD MyCloud to try if it installs…

from what you are writing it appears as if in MyCloud there are some extra layers of secuity that prevent from installing third party scripts/apps (I guess WD wants to put some order in this area, and according to a post in the MyCloud EX4 forum, they are calling out on developers to help out, but I guess they will try to place their seal on apps thrown at their devices)…

This is just a thought… I do not actually know WD policies or if this is the case…

maybe you could try placing the btsync file outside the Public share (either in a private share or somewhere else under root) and see if you can run it from there…

Solved!!!

WDmycloud has an arm cpu , so i downloaded the arm bin and with it is goes well , you can faind the screenshot in attach .

Now a question ,do i have some configuration ?

The bit sync restart alone at the boot?

When bit torrent make an update how can i do to replace the bin ? is it only to replace btsync or have i to stop someting ?