Another Brick Help Thread! HELP PLEASE

So, trying to install miniDLNA on my device is ended up bricking my 3TB my cloud. The tutorial I was using as help, had install from the sid repo. Anyway, so my my cloud won’t boot, and all I get is a solid yellow light.

I have read over all of the recovery threads and it look like all I have to do is flash a new img. Problem, I don’t have a computer with a open SATA port. My main computer is a iMac, which I cant mount a drive in.

My two options, if I flash the image from my mac, to the mycloud hardrive, plugged into a sata - usb will that work? I
also have a wd mybook that I could swap drives in and flash the image onto. If I put the mycloud drive in the my book, mount it to the imac, and flash the image over, will that work?

Any help will be appreciated. Thank you. If none of these work, how about getting the drive working to pop into a harddrive enclosure to use attatched to my Raspberry Pi media center. What are the steps involved In that?

Hi there Justin… I had exactly the same problem when trying to install miniDLNA from the repo… I was lucky as I had linux computer to do the recovery… you have to take it apart if you want your data back…

when its out you can try to connect it to your mac both ways… whichever way will give you access to all the data and partitions is the best way… also I dont have any experience in doin this on mac (even tho I have mac myself)… If I was in your place I would try to swap it with mybook… download any software to make virtual machine… install some free linux distro on it (ubuntu) and rewrite the rootfs partitions ( .img)

EDIT: I am not sure about raspberrypi as I have one myself and when I tried to connect the drive to it directly with SATA-to-USB cable it didnt work… but its worth a try as raspberry already has linux on it…

Wow such a quick reply thank you very much
I have flashed images from my Mac before. so basically is that all I have to do to get this drive back up and running? without messing around with installing Ubuntu as a virtual machine on my Mac

the drive on the mycloud was empty as I backed up all my data before so getting any data back is not a problem. I emptied the drive and did a reset before downgrading.

As I said I dont have any experience with doing this with mac osx… but it actually might work… if you are willing to test it ti would be cool as I could next time just do it with my mac… and if it fails you can always do it via the virtual machine…

Ah alright… I already have 3,5TB used on my device so backing it up somewhere is not an option so I just mentioned that your data wont be touched :wink:

You can put the hard drive from the My Cloud into any SATA to USB dock / enclosure and use a Linux OS to unbrick. There are various Linux boot discs one can download and burn to a CD/DVD/USB flash drive and boot the computer with that Linux boot disc to unbrick the My Cloud drive. Unbricking will require some knowledge of how to use the command line terminal in Linux and commands that get issued via that terminal. And opening the My Cloud enclosure will in all likelihood void the device warrantee.

There is also the following option one person claims to have used that didn’t require opening the My Cloud enclosure:

https://community.wd.com/t/unbricking-without-opening/95064

so after cracking openthe case thr mycloud n pop in the disc from the my cloud in to my book I couldn’t get the Raspberry Pi or the mac to - see the hard disk. They would see the usb interface from the my book but not the actual disk. They are the exact same Hdd so idk why. They both would mount th mybook with the right hdd in it.
I guess a virtual machine is my next option.

So you were not able to see the disk under Disk Utility?

No could not see the drive under disk utility. Or under gparted on the raspberry pi. Idk if it was the mybook not interfacing with the drive or inability of the OS.
My broke ass is on to buy a sata to usb and give that a shot.

did you try to create the virtual machine with linux and do it with that?

yes, I tried to do it on a virtual ubuntu machine. i believe its the mybook enclosure. IDK why, they are the same exact 3tb NAS drive in each. the mybook mounts fine with the proper HD, but wont mount with the MY cloud drive.

im going to buy a usb - sata and give it a shot, once i have a extra 20 bucks to spend

have you tried what Bennor suggested Unbricking without opening ?

Is the MyBook just enclosure with SATA connector or is there chip on the SATA like in MyCloud? it might be that the chip is not recognising the OS on the MyCloud HDD… I wonder when you connect it via the MyBook enclosure to the ubuntu virtual machine do you check just the gparted if its connected or did you try to run terminal and run something like /proc/partitions or fdisk -l to see if the system can see the device but maybe it just didnt mount it properly

there is a small pcb in the the mybook. idk if it does any processing inside of it, but it looks to be more than just a sata - usb.

I did not do what bennor said, as i had already opened the case. Ill look it over and see what it may involve. I am completely locked out, no ssh or anything. IT wont even show up on my router as a connected device.

Yes is tried fdisk - l, df to see if it was mounted at all on the ubuntu machine and no dice. Again i could see MyBook 1234 connected under usb devices but would not show as a drive. I honestly think the pcb in the mybook is a little “smarter” than just “dumb” sata - usb

well then I dont know what to do… I didnt have SATA to USB cable but I was lucky as my friend had stationary computer so I just made bootable Linux USB took my HDD to him and did it at his computer. I didnt have to buy the cable… if this is not an option then you have to wait for the cable :confused:

ya, since i became a father of 3, and with everything going on in my personal life, I have no friends, let alone anyone in my family who is tech savvy.

Ive been racking my brain to think of someone who would let me pop in my HDD to there computer, but I dont know anyone who will let me open there computer without freaking out.

■■■■ imacs

where are you from?

I live in a small hole that leads straight to hell, in the mid east called, Delaware

. So i installed ubuntu on my mac and was able to get some more info, the my book shown up in disks as a 3tb hard drive on but would show no media with the My cloud drive in or with no drive in. Im guessing it has some type of chip in it. Also theres a 210mb efi partition that im guessing holds boot info.

So just replying to let ya know. I bought` a anker usb to sata and my !ac recognized the drive!! Disk utility is in the procesa of flashing the 3tb image over.

1 Like

where did you get the 3tb img at?

I found it after a few indth google searches. I believe it was in a posted in a thread on here. I can share it with you on my dropbox if you would like.

Btw, its up n running. Done on a mac. :smiley: :smiley:

It will probably wokr… I was talking earlier about rewriting rootfs which you get from firmware you are probably doing something else… is it finished?