Adding a drive to EX4100 without losing data

I initially installed my EX4100 with one 6TB drive. I added a second 6TB drive today and every option I am presented with for prepping the drive says I will lose all my data. Fortunately I have a back-up. What is the best configuration to set the drives up so when I add a third drive I don’t go through this again?


If you select the option “Switch” it will reformat the two disks but if you select “Migrate” the data on the first disk will remain. Now, I would recommend that you migrate to RAID 1 so when you add the third disk, you will be able to migrate to RAID 5 without having to erase the data on the disks.


A lot of forum moderators and WD staff are saying this should work, but as other people have said the documentation and procedures for doing this are very poorly documented or non existent. If WD have procedures for doing this, then it would be an excellent idea to share these with the community.

I for one have tried to convert a 2 disk RAID 1 to a 4 disk RAID 5 and followed what little I could find on it and it does not work. I selected the options to “Switch” the RAID mode and it went off and did something for a long time, but ultimately somehow ended up with a 4 disk RAID 1 (as per the output from “cat /proc/mdstat”). I then tried to “Expand” the drives and somehow think the NAS go into a state where it wanted to constantly swap a drive in and out of Bay 1 with no way to disable this.

In the end I was fortunate that I had another NAS that I could back up about 80% of my data to and used this as temporary storage and rebuilt the RAID from scratch. Not everyone who has this sort of device has the luxury of another temporary storage device available, especially when large capacity drives are in the picture.

Subset of other similar threads below :

and I am sure there are probably more.

Here is the thread on my own experience in trying to do this from some time ago :



Just as an update: I received a response from WD Support indicating that the appropriate procedure was to navigate to Storage → RAID → Expand RAID 5, then replace the drives one-at-a-time as prompted by the LEDs.

Unfortunately, the system never acknowledged that the drives had been replaced, instead continually insisting that I replace the disk in bay 0 (which I had already done). Eventually I just used some extra drives I had laying around to copy the data off, build a new RAID, then copy it back.

It took the better part of four days, but at least everything works. I know many aren’t lucky enough to have that much spare storage (and I’ll be stuck if / when I need to enlarge again), so hopefully WD will recognize the issue(s) and fix / improve the process.