50% of my BD MP4 files are not recognized by my WDTV Media Player

I use MakeMKV to rip my BluRay movies and the convert them to MP4 format using HandBrake, with a High Profile setting. I then use MetaX to write the Metadata to the file.

About 50% of the files are not displayed in either the Video or or File app. If I change the file extension from MP4 to M4V the files are displayed and can be played with no problem. However the Metedata is not displayed when I use the m4v file extension.

Is there a setting I should change in HandBrake the let the WDTV Media Player recognize the MP4 file or is there a way to have the player recognize the Metadata on a m4v file.

I’d recommend double-checking the conversion output. Some codecs are not supported under specific containers. Since videos do play/show when changing the extension then the conversion process is not modifying supported parameters.

I compared the the files that worked with ones that did not using Mediainfo, using the tree format. I did not find any differences between the two, other than movie specific info. I am at a total loss as to why some work just fine and others don’t. The Codecs were identical.

Known issue, from 2014.
Old conversations here already had given indications.
Try a search… The solution was double: first, WD TV Live has a feature that goes to check on the Internet for album covers atc, and the file can be considered “music” and not video, so you will have only the audio.

Other problem is that the latest firmware does not plays some .mp4 video files, and you should rollback to previous firmware.
In old conversations there are also instructions on how to do that.
Hope you can resolve

here is the link

I don’t think this applies to my problem. I am using WDTV Media Player and the firmware version is 1.02.17.

Sorry I can’t address the thrust of the problem, but I can describe (I’ll call it), a “toggle” with regard to refreshing the WDTV database as you make attempts (in whatever manner) to fix your problem. I say this because getting WDTV to refresh can be opaque in itself - IF you are running shares to WDTV using the “media server” option (probably not!). This method definitely works but I just don’t know if it works for ‘network share.’ So sorry if the following doesn’t apply (or if this is too basic to be of any help).
The only method I’ve discovered that is guaranteed to refresh, is; “Control Panel”, “Home Group”, then click “Allow all devices on this network such as TV’s and game consoles to play my shared content”, (there is where your devices appear) and choose the option BLOCK ALL. Fire up WDTV and try to access your media (obviously it will say “no file” or similar) and that’s it. Switch WDTV off and go back to “Home Group” and now the option “Turn Streaming On” will appear and you can turn that on, then switch WDTV on once more. At least then you can know the library has been refreshed. (Sorry if all this is irrelevant in your case).

Thanks for the tip, but I don’t think it applies to my situation. I am using WD portable disk drive plugged into the usb port to access my MP4 files… I have pretty much given up on finding a fix.

So now Handbreak my file to MP4 format and if the WDTV Media Player doesn’t recognize the MP4 file, I just rename the file to m4v file. So far it always recogives and plays the m4v file. I then add a jpg file with the same name, that contains the movie album art. That way it displays the art in the Video App.

Sorry to hear that. The folk in this community are not easily beaten. My own WDTV media library never accurately reflected what I have on my (non network) hard drive until a few days ago. It was a bit of a weird one, how I fixed it. It was the link I give here. The undoubted expert has a panopoly of things to offer, that can be tried for network shares not working properly. (In my case I was flabbergasted to learn that the fix for my situation was a value of “0” needing to be input in Windows ‘search’ where it had an [apparently inappropriate] “1” for some reason). Whereupon for the first time WDTV media library was an exact match for everything on the hard drive. Everything present, as named, none absent. Weird indeed. You may wish to have a look (the guy knows his stuff):-

I followed the instructions in the link and indeed did find the the value was 1. I reset it to 0 as instructed, rebooted my PC and then renamed one of my problem files back to a MP4 extension. I then put my hard drive back on the WDTV Media Player USB port. Unfortunately, it didn’t work. The file was not found. When I renamed it back to the m4v extension, the file was once again recognized.

I am now going to rip a few more Blu Rays and see if the new ones will work. I will let you know, but it may be a few days.

Yes Thomas, let us know. This thread is not dead yet I’m sure! There are some folk who might be able to crack it for you. Also, if you haven’t lost the will to live and feel so inclined, just going over previous posts here (bet you have already) might just unearth some clues.

I ripped the new Blu Rays. Two out of the five worked as MP4 files and the other three I had to rename to m4v files for my player to recognize them.

Not good, no. Although I’ve had no real problems with the WDTV I have now (the first one I threw away, it just seemed irredeemable; £70 quid down the drain), clearly what you’re getting is annoying. Inexplicable to us, I hope someone weighs in with an understanding.

To be honest, even with my good unit I’ll admit I have one - one only, Mp4 file that currently does not show in WDTV. And that after a clearout, turning off sharing in Windows to force WDTV to read my files anew because it had multiple entries after I changed filenames. (You know, after ripping they can come up, for example, ‘DAN_…76487C_’ or whatever). Also, I’ve name changed some names more than once to get them in the order I want in WDTV’s alphanumeric list. So WDTV listed some 3 times or more, one for each name change!

As I say, shutting off Sharing fixed that but, but, but - the good bit - it also brought some into WDTV’s list that were failing to display, which was why I described a guaranteed refresh method. And now it seems, the rot has begun again. A file I did the other day (even tho’ it’s only one) already WDTV isn’t displaying it and as I only have Mp4’s, I can’t imagine why as they don’t differ.

Now, somewhere I saw a detailed description of returning WDTV to its factory default state and I’m saying that because it had about 3 extra steps to get it done correctly, over and above how it’s described in the manual. Convinced me the manual itself is insufficient on the topic! So far, I can’t find where I saw it, but I’ll post the link here when I find it again. As I’m little or no help, Thomas, I’ll get off the airwaves!