1 Reallocated sector, 728 Pending, Raw read errors 65843 Error UNC 8 sectors


#1

Hi, I have a laptop disk - 209 days into the warranty, smartctl showed that I had 1 reallocated sector and 728 sectors pending with 65843 raw_read_error_rate. I did not have a backup disk so I waited for almost a year - finally did the backups and then erased the disk for RMA (it’s under warranty)

To erase my data I ran ddrescue on all the bad sectors using the recovery-log then i erased all the good blocks and then i ran badblocks - 1 pass 1 pattern. I’m currently running the SMART extended test.

What I notice is that I have that old error 1 reallocated/remapped sector and a whole bunch of DMA erros recorded in SMART BUT the raw_read_error_rate has been 0’d and so has the pending sectors.

  1. Should I RMA this disk?
  2. If I RMA it what exactly are the guys likely to change/replace? Controller-board seems to be working, so is it likely they will swap the heads or change the platters - given that I only have 1 reallocated sector?
  3. A google doc says that once a drive generates bad sectors it’s toast mostly and will go on to fail. I’ve had my disk sitting on a shelf for the better part of a year waiting for a backup disk and time… (not an expert and I had to recover my data). Should I continue with this working disk or risk an RMA?

#2

Hi veek,

You should apply for the RMA and replaced drive would not be the same drive it would be other one.

You should refer to the link given below in order to apply for the RMA to Replace a Defective Product.


#3

HI Alex, Thank You for replying because I had decided not to RMA the disk - it didn’t seem worth it, with only 1 damaged area. Okay, I’ll get in touch with the guys doing the RMA - Flextronics, in this case.

Many thanks.


#4

Hello again, alex - the replacement disk has more problems than the disk I gave them.

This disk doesn’t boot/work at all!

The service center opens at 9.30 and is a 5-6 hour drive considering the traffic in Bangalore - I will send the disk via post but the disk is so bad it looks to be deliberate.

Linux doesn’t even load and it took me a day to figure it out because it worked intermittently (badblocks for 8 hrs overnight, couple of hours of install and restore from backup, then it failed the boot, so i had to run badblocks again and SMARTlong and blank the disk pending it’s return (4hrs)).

Could you call the service center (Flex BLR on Hosur Road) and ask them to return my original disk - that had 1 reallocation event and was booting fine when I handed it in.


#5

The warranty period on the replacement drive (262U9TBJ after RMA) has been shortened as well (by a month), my warranty on the original expired on 25 Oct (10) 2018