Windows 7 and Network Connections


#1

I have a HP laptop that I recently connected to my MBWE 1TB network drive. Windows found the drive on the network and allowed me to access the drive. In fact I was able to download data from the MBWE to my laptop, no problem.

The problems began when I tried shutting down my laptop. It would hang for a long period and then I would get a BSOD. The error indicated that it was an issue with one of the drivers. It was a Driver_Power_State_Failure.

I began researching which drivers might have caused the issue. I had recently upgraded my Norton Internet Security to the 2010 version. I thought that this was the culprit but after removing NIS10, the problem remained. I had updated JAVA, so next I rolled back the earlier java version and the problem remained.

After reviewing the drivers under device manager, I kept overlooking the MBWE driver that was installed when I connected to this drive for the first time. I disabled the driver and then un-installed this driver. This process resulted in the device manager hanging when trying to close both operations. However, after another hard shutdown. The driver was in fact removed, I then attempted another shutdown and it succeeded.

I offer this thread as help to anyone else that might be experiencing a similar problem.

Is there a new driver download or upgrade for WD Discovery for compatability with Win7-64bit?


#2

Hi,

I’ve been having the same problems with Windows 7 not shutting down on my HP laptop, with the eventual BSOD. Once I physically disconnect my WorldBook 1Tb I can shut down without issue. 

Any updates would be appreciated. 

the other option is a different NAS system.


#3

hi again,

i’ve got a Mac OS 10, and a PC windows XP on my network as well with no problems. The problem seems to lie with Windows 7 Home Edition.


#4

  Wish I could help more guys, but all I can really say is this:

  I’m running Windows7 x64 Ultimate. And two MBW2 NAS devices on my network for the last (well, 1 for a year with the second added about 6 months back) and have _never_ experienced this problem before!

  I do, however, remember that the Windows Auto-Update service offered newer drivers for the devices not too long back. You may want to check for that or if you system is managing that for you go check your update history… If a new driver has been auto-installed recently try rolling back. If you haven’t had a new one installed yet try searching for and installing it.

  I know I actually ran for several months without ANY drivers for the devices installed - these are NAS systems so strictly speaking you don’t need typical drivers… You might want to keep that in mind too as an option.


#5

I too have this same problem running Win7 Home 64.  it also stops the USB ports on my HP notebook from functioning if the MBWE is one the network when the notebook boots up.

Anyone find a cure?


#6

I also have the same problem.  It seems to be temporarily abated by having windows 7 uninstall the device.   My networked drives still work and I’m able to use the device.  Whenever windows redetects the drive and tries to install a driver for it and wham… BSOD on shut down or restart.  It also interferes with the touchpad and removes power from my usb ports.

I have a new hp pavilion dv5 with the My Book World Edition II drive running windows 7 Home Premium 64bit edition.  Anyone else found a permanent solution?

Is Western Digital working on this problem?  I’ve seen posts in other forums about this same issue but nobody has a reliable solution.  Some have offered updating the firmware or changing windows upnp under services from automatic to manual…but mine is already set to manual.

I"m running the latest firmware (nov-09 i believe) and when i install the driver under windows it says that it fails.


#7

Same here. HP HDX 16 Win7 64. I have just disabled the device rather than un-installing. Now closing down ok. Is this a 64bit problem?


#8

It runs fine on my Vista 64bit machine so I believe its just windows 7.  I’ve emailed western digital about this problem and contacted HP since microsoft says HP has to troubleshoot windows for me as an OEM.  HP says i have to pay $60 to get tech support on this issue involving a 3rd party product.


#9

I have the drive connected to the network.  I can access the network manager, however, I cannot map any drives either automatically or manually and I cannot access the drives via explorer.  This is my second unit; I had the same problem with the first unit.  Can someone please help?  I’ve called WD helpdesk and they are totally useless.  I was informed that they do not support the unit being connected to a network.  Am I missing something?  Isn’t the unit primarily designed to be used  via a network???


#10

Please help; can anybody offer any help?


#11

Those problems are weird since I connected many PC’s in my house with the MBWEII without a single problem. Even with HP’s. My sister’s HP laptop with Seven x64 and an HP Touchsmart with Seven x64 are accessing the drive without experiencing any problem.

But the thing is I NEVER installed the WD Discovery tool or any related drivers to any computer on the network. I just went on all computers and in Windows Explorer, in Network, clicked on the MyBook then I right-clicked on the Public folder and clicked “Connect a network drive” and I chose the letter T: . All computers are seeing the Public folder on the T: drive.


#12

Thanks for the advice, however, when I tried this method; all I get when I click on the drive in explorer is a redirect to the network manager.  I am using Windows 7.


#13

But do you have any WD driver or tool installed ?


#14

no


#15

Then it must be in conflict with another software … can’t help anymore then …


#16

Hello,

I’m experience the same problem, I to have a HP laptop running VISTA, is this problem related to HP laptops?

one please help us its driving me mad!!! There must be a solution

Regards

Guy


#17

I have four systems using this drive on my network. 1 PS3, 2 WIndows 7 64 bit and one Windows XP 32 bit. I am not experiencing any problems with any of them. There shouldn’t really be any drivers involved since it’s a network drive. You should call WD back and tell them they better darn well support plugging a network drive into a network.

You can always return it to the store you purchased it from and tell them WD is not interested in helping you.

If you are in Canada you can contact Consumer Affairs Canada. They can force a manufacturer to stand behind their warranty, and fine them if they don’t.

If you live in the UK, you have other options. There are laws regarding the sales of devices that work properly. I’m not familiar with all the UK laws so you might have to look into it further.

If you’re in the U.S., I’m afraid I don’t know what your options are. You may be screwed.

Here’s some advice that MAY help if you haven’t already tried it:

Go into the settings log-in in your browser (192.168.1.100 I think). I believe the default log-in is: admin admin. Bookmark this page so you can get at it easily.

Look in the advanced network settings and change your IP from DHCP to static. If you have only one computer in your network, you should be able to use: 192.168.1.9 as your IP for the drive.  It’s actually up to you to select an IP address that will work on your system. The one I gave you should be OK. If you have multi computers on your network, just select an IP address above the top address in use. Type ipconfig into the search bar in win 7 to see your current IP address. Since you are using a network drive I assume you’re using a router? So set the drive to have an IP address that’s your IP address plus 5. That should give your router lots of room unless you have more than just you on your network.

Change the workgroup name to reflect the workgroup your computer belongs to. If you have never set up your workgroup (which is basically just telling windows 7 a name), do so now. Check help if you don’t know how or look it up in Google.

Go into the power save settings and turn off the power save feature. I have found that the PS3 cannot wake up the drive once it goes to sleep. This MAY have something in common with your shutdown problem.

While you’re in there, change your password so it can’t be easily accessed by anyone else.

Close your browser. Reboot your computer. It may say it cannot mount your drives. If this happens, go into “Computer” and “remove” all the network drive icons (right click on them and select “remove”). Rerun WD Discovery and let it automatically remap the drives again. It will create new icons in “Computer” (I wish MS had of left it called “MyComputer”).

After all this, your drive should work from the network, and it should also be shown in “Computer”. If you selected it you should also have an icon on your desktop. You should be able to access all the mounted drives from that icon.

If none of this works, I would suggest shutting off the drive before you shut down your computer.

Personally I believe it’s a problem with the HP laptops. Of course, HP refusing to help you unless you pay them is why I refuse to purchase HP products any more. Their hardware is usually OK, but their attitude ■■■■■ really bad. I have control over what the business I work for purchases for IT and other hardware. We have zero HP equipment.

I’ll likely never be back here since the forums here are pretty sparse. I just dropped by to see why the transfer speed of the drive did not improve when I replaced my router with a Gigabit router. I should have seen a performance improvement like I do when copying to other computers on my network. Unfortunately the transfer rate is exactly the same which makes me think it’s not actually  a 10/100/1000 drive, but only a 10/100 drive. If I can’t find an explanation for this I may submit a complaint myself to the BBB and CAC. When I bought the drive two weeks ago I only had a 10/100 LAN. It’s now completely upgraded to 10/100/1000 and the only things not showing any improvement are the network drive and the PS3.

Good luck with your problems guys. After hearing about what a hard time people are having getting WD to support them, how lame the tech support is, and how slow they are, I don’t think I’ll be purchasing any more WD products either.


#18

I absolutely agree with you, WD have no support!!! They answer on emails and phone calls like trained monkeys, however they will not help you, they have no solutions. They ignore customers problems and they try to hide their own BUGs!


#19

WD does support our network drives within a network environment so I’m not sure why someone would have said that we don’t support that.  Nonetheless, we have released firmware 01.02.04 within the last week so I recommend updating to that.  I also recommend installing the latest Windows high priority and optional updates, particularly network drivers.  If you do not have the latest wired/wireless drivers installed, the connection with the drive may not be consistent.  Updating the router’s firmware would also be advisable.

Please note that the MyBook World itself needs no driver to operate but we published a network driver through the Microsoft Windows Update so Windows will show the MyBook with a picture that looks like the drive within Windows’ “Network Map”.  You can disable or uninstall that device within the “Disk Drives” section of Windows “Device Manager”. 


#20

Those are political answers, where is the solution?

When you are using W7, don’t use Microsoft Windows Update driver, it will make you problems with your WD MB. 

So your advise is to make more and new problems to the customers!

Very good WD, perfect support!

Thank you…