Windows 10 can't see My Cloud workaround

Very interesting! Wireless works.

Well, I’m wired Gigabit and I still don’t show the WDMyCloud and I do have NetBIOS selected. But I wonder If I disable NetBIOS and then re-enable it … I wonder.

Oh, I must check my Netbook (wireless) and see if it shows the WDMyCloud under Computers.


Don’t forget the file and printer sharing.


My wireless Netbook (Win 10 - latest build) also does NOT show the WDMyCloud under Network. {Sigh… }


Thanks for posting this. My ‘MyCloud’ not showing up under ‘Network’ in Windows 10 file explorer was driving me up the wall.

There are 3 Windows 10 computers on my network (1 Pro, 2 Home; all on the 1511 version).

I could remote in to the UI using the IP address. Windows File History shows that backups are being made on a regular basis. I just couldn’t see the NAS under Network. As above, I can see it under Media Devices and Storage.

The NAS would show up on the Pro desktop, but not on a consistent basis. The Home versions would never see the MyCloud in Network.

Good to know I can access it by typing it its name (e.g., \WDMyCloud) and accessing files that way.

One of my systems (a Windows 10 desktop MCLC2) shows both the WD MyCloud in the Network and shows it under Computers as well!

Not sure why that desktop displays the MyCloud correctly but I’ll check this out further. That desktop is Windows 10 but pre-November update so maybe that is it. It also happens to resides in a different segment of my network (about 1/2 Km away and connected by a wireless 2.4GHz link). The WD MyCloud is not in that segment with MCLC2 but is here in this segment with ASUS-CG8480. Odd.


Confirmed. Windows 10 latest release (.36) is the cause of not showing the NAS devices in Network.

Before and after the November update.

Will Microsoft fix this I wonder.


This morning I found that devices were missing from the network tab. I followed the directions in the following location:


I have Enable NetBios over TCP/IP set ON and I still do not have NAS devices showing. I have always had Enable NetBios over TCP/IP ON. I am waiting for Microsoft to fix this.


I rebooted my system and the devices were not listed under network. I clicked on the network
and the devices showed up. After that they seemed to show everytime. Strange


There is potentially an SMB issue with Windows 10. I have found that changing the SMB setting either in the My Cloud or on my Windows 10 PC seems to fix the missing My Cloud in the File Explorer. Unknown how that change will affect file copying speeds though.

See the entry titled Method 6 in the following updated thread…

The best solution I have found for the My Cloud disappearing is to make my router the Samba Master Browser and to turn off the Computer Browser service in all networked Windows PCs to stop contention issues.

I also reset the network on a couple of troublesome PCs with netcfg -d and after a reboot of the PC the My Cloud appeared. (Use with caution.)

Which, as you pointed out in your other thread, only works if one has a router that has a Samba Master Browser option. If one’s router doesn’t have such an option they can either change the SMB2 & SMB3 settings on Windows 10 to SMB1, or change the SMB2 setting on the My Cloud via SSH to SMB1.

Edit to add: Updated the thread Compilation of Windows 10 Methods, Steps and Solutions to include the router / My Cloud Samba Master Browser fix in Suggestion for MyCloud poor responsiveness over Samba. There are now three SMB options to try.

I had the same problems detailed above. But this issue apparently has been resolved by Microsoft. As of today I can finally see Mycloud in file explorer!! Hip Hip Hurray!!

No it hasn’t. People (including myself) are still having problems even with the latest update released a day or two ago with Windows 10 not properly accessing Samba shares. See the following thread where there is current ongoing discussion on the Windows 10 problems with the My Cloud.

And the following thread which contains a compilation of possible workarounds or fixes for Windows 10 users who experience problems with the My Cloud.

yes i did have an issue with samba 3.1 and win 10 i decided to update to the creators build … windows now uses smb 3.1 and getting it to mount took a bit but it works although slow avg 15-20 up

i decided to let the stock settings control things i turned server smb off and set client smb on and now it is a matter of getting it faster…

just change the name of your workgroup and it will reappear
then change it back if you want ,it will stay
I been through this about 10 times already ,this is what solves my issue

How I managed to access my MyCloudEXUltra shares on Win 10.

In our office we used the WD My Cloud personal storage as internal server. It worked perfectly for two and a half years. After one of the win10 upgrades, the device began to disappear from the network. Become very slow or not available at all. So we started every working day with the restart of the device and than it works for all day. I have access to the dashboard, no issues there. I ran quick and full diagnostics tests no issues there as well.

After these issues I was concerned about overall health of the device controller so we purchased new MyCloudEX2Ultra NAS server. And then it started. We did not not see shares on the network. I tried everything I could find on support pages, nothing worked for me. The thing is that it shows under network storage devices, but not under computer and I can not access shares. I can access dashboard, no issues there, I did firmare update, created users, shares but nothing helped to access shares on windows explorer.
I could ping server IP. I have turned on network discovery, file and printer sharing. Set workgroup. Enabled NetBIOS over TCP/IP. Windows sees NAS, but can not display folders.


I started a small program - ipscan25 (no need to install). Scan the network, all connected devices are displayed. Clicking on the MyCloud’s IP addresses can open file explorer. From there you can pin your shares to quick access. As soon as this route is specified and opened, the device appears on the file explorer network. From there you can do drive mapping for the necessary shares to my computer. Or just use quick access shortcuts on your windows. This process has to be done on every computer that needs to access the cloud.
So far, everything is working fine.

I have the same issue and am trying to find a solution now. Done all the obvious. I can map a drive but can’t browse. Must be a windows 10 setting somewhere 'cos some people seem to be able to browse with no problem. My “Network” section in explorer is empty!! Strange. Windows does seem to be fraught with these problems. Wonder why.

Hi all, sorry to pick up this old thread. I just had the very same problem with a freshly set up windows 10 box so I thought I post my solution here.

The setup is a home windows SMB network, with Win8 and Win7 on laptops and workstations, 2 file servers are running, one is Win10 and one is MC, with SMB3 enabled. Passwords are set up everywhere.

The strange thing was that MC was not visible from one of the Win10 boxes, yet visible from anywhere else in the system.

Turns out I had to enable SMB1 in “programs and features”, “SMB 1.0/CIFS File Sharing Support”.

No idea why, my expectation was that everything SMB3 would cover it all.

Hope this helps.

A recent Microsoft Windows 10 update may have disabled/turned off the SMB1/CIF option. WD has a knowledgebase article discussing how to turn the feature back on:

It should be noted that the reason Microsoft disabled this feature is due to security vulnerabilities. See the following Microsoft blog post. So reactivate SMB1/CIF at your own risk. One can still access and map the My Cloud using the device’s IP address or possibly the device name.

There is a section (method 3) in the WD Community Compilation of Windows 10 Methods, Steps and Solutions thals explains this issue.