WDTV live services not working

I’ve had my WDTV Live for a few years now and it has always worked great. 

I moved around a month ago and just can’t get any apps to work since then. The network connection is good, I can access my computer from it (windows share) and I can access the HD that is connected to it with my laptop. I can play files without issues.

When I go to Services / all apps, it says there are 83 apps total but I can only see a few, the other ones have no icons and I get a white page if I click on any of the “invisible” icon. 

When I click on netflix, the netflix icon appears offset to the left of the screen and nothing happens.

I tried VUDU and it says “can’t retrieve data” or something like that.

With accuweather I can see today’s temperature but the 7 days forecast only shows 2 days.

I have the same router I had at my old place and use the same internet provider.

I have the latest firmware.

I tried a factory reset (twice) and issue is still there.

Anyone can help?

Welcome to the WD Community.

I haven’t seen this case before. 

Have you tried a physical reset? 

Are you using the unit wired or wireless?

I tried a physical reset (3 times) and it is still not working. The device uses a wifi connection. I was able to get Pandora to work and that’s it. Again it can connect to the network, but not to the internet.

Maybe try a factory reset via the UI ?

Setup > System > Device Reset > Reset All Settings Back to Factory Default

or … you could try KAD79’s solution (requires a little more effort, but worth a try)

http://community.wd.com/t5/WD-TV-Live-Streaming/WDTV-Reset-EVERYTHING/m-p/845085#M35071