WDS240G2G0B Boot Issue


I recently upgraded my processor from Ryzen 7 2700X to Ryzen 7 5800X3D, but I’m experiencing compatibility issues with my WDS240G2G0B nvme M2.1 SSD. I have already installed the latest BIOS version (7B86vMJ). Installed OS was updated Win 11 Pro. When I boot PC system is first stuck at BIOS post screen for a while. Then enter the BIOS, I can see there CPU speed, fan speed etc but no OS loading screen. I tried old BIOS versions but nothing happened. As I remember OS installed drive was GPT. I tried to install fresh Win11 but Win11 installer can’t detect M2.1 drive but I can see it in BIOS. When I select a GPT SSD for Win11 installation, it gives an error like “can’t create a partition or find the partition”

A spare SSD converted to GPT in another PC and installed Win11 with MSI B450A Pro Max. OS installed SSD is: KINGSTON SV300S37A120G. The OS takes 7.5 minutes to load with the Nvme SSD installed in the system. When I remove the Nvme SSD from the system, the OS loads in less than 10 seconds. I installed WD Dasbord on the computer but cannot detect the nvme SSD.

Somehow, there is a mismatch somewhere but I can’t figure it out. Any idea?

System info

OS - Windows 11 Pro
Mobo - MSI B450-A Pro Max
Ram - 4x Kingston HyperX Fury 8GB 3200MHz HX432C16FB3/8
SSD - WD 240GB Sata Green M.2 SSD WDS240G2G0B

Hi @UmutOzan,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:


I tried four times but failed with the below message.


Try this SOLVED Problem with not detected new SSD in Disk Management, Win installer

Here is an update about my SSD problem.

WD Customer Support return my issue with “We will be more than happy to replace the affected product under the Warranty Replacement Policy”

1 Like