SOLVED Problem with not detected new SSD in Disk Management, Win installer

I bought used like new WD SN850x and cant founded it in Disk Managment like a lot of people here. Also I cant install windows on it - not detected by installer. In BIOS SSD detected fine.
I though that a SSD broken… but deside install Ubuntu. And i was surprising - all installed perfect! Then i try to install windows againe - and surprising againe - installer showed SSD now! Also SSD showed in Disk Managment. I hope this information will help someones.

Hi @vborets,

Resolve Internal Drive Not Detected by Windows or macOS Quick Assistant: Resolve Internal Drive Not Detected by Windows or macOS Guided Assist

Please contact the WD Technical Support team for the best assistance and troubleshooting:

@Keerti_01 Your “resolve” not working… and it`s prooved by a lot of people.

The simplest way - install Ubuntu first

Hey there! I had a similar issue with my WD SN850x, but luckily, I found a workaround. When I couldn’t detect it in Disk Management or install Windows, I was getting worried about a broken SSD. However, I decided to try installing Ubuntu as you did, and surprisingly, it worked perfectly! After that, when I tried installing Windows again, the SSD showed up in the installer and Disk Management too. It’s strange, but at least it’s working now. So, if anyone else is facing this problem, try installing Ubuntu first, and then give Windows another shot. Hope this helps someone else out there!

1 Like