WD2GO Pro?

I just setup My Book Live remote access and download the WD 2go app to my iphone.  In the app they have a help section and it keeps mentioning a WD 2go Pro app.  I cant seem to find this app any where.  Does anyone know anything about it?  It says it allows you to upload and download files from your device to your My Book Live.

Wow, that would be awesome!

I also saw this and am wondering when this is going to be available. I would love for this to have more features so that I can use it as my personal cloud and not have all my stuff on a random server somewhere.

WD 2GO Pro is now available … however ( now you knew there would be one ) have installed on my iPad 2 and activated but it fails to view shares on MyBook Live :frowning:

WD 2GO still works fine, just not the Pro version

Can you give me some more details? When you created the DAC, did you have use admin or the specific user that can view the share?

Do you see any of the shares (e.g. Public) after you select the NAS? Also, curious - what if you switch networks (3G or a different wifi) do you see anything? The shares view is the same code base in both standard and pro - so is surprising that this would be different.



Hi Raj - Used a specific user ( not Admin ), and no it couldnt see any shares - not even the public ones.

There was an error msg that came up, which of course I didnt note, however will try again when I get home and will let you know …

thanks for getting involved

Any idea if this is an Ipad only app? Don’t see WD2GO Pro on the android market anywhere.

Actually found it  - had to type in “WD 2GO PRO” (proper spaces location).  Guess the only thing I am still unclear on, is can you open a file from your WD Live, edit, and then save back to the drive (without emailing, etc.). 

I guess in other words, is this now as seemless as drop box? If so, I will finally be ordering one.


Hi Raj, so created a new DAC with a specific user that can view shares.

Entered DAC into WD 2GO Pro, and it lists MyBook live correctly.

However when I go look at shares, none are listed and the following error msg comes up …

Device Offline - The Device is not accesible. Local Documents are available. (F.11)

Like I said I still have WD2GO loaded and it works perfectly.

Ideas ?


A Little bit more information …

Tested on iPad2 and iPhone4, and WD 2GO Pro failed on both, using a local Wireless link.

MyBook Live is connected via standard Ethernet cable to Wireless router.

Removed both WD 2GO Pro and WD 2GO apps, and reinstalled just WD 2GO Pro.

Generated new DAC, and again WD 2GO Pro recognised MyBook Live, both refused to show shares ( same error msg as before F.11 )

*** Just tried accessing via Public Internet, rather than home network, and WD 2GO Pro works fine !!!

So any ideas why it wont work on my home network ?


We had one user who was using a guest network within his home that was blocking access to his MBL and when he tried over 3G it worked fine. Have you setup something similar?

Internally the app uses bonjour names (mybooklive.local) within the LAN to connect to the device. In the WAN it uses its fully qualified name. I’m wondering if the router is blocking. If you can share your router make/model and any settings that you may have set on either mybooklive or router I can check with our QA team to see they’ve seen anything.

Also, if you wouldn’t mind also trying the experiment again on the WD 2go standard edition to see if that works within your LAN. We did some optimizations in pro that didn’t get into the standard release around IP lookups and want to see if there’s a correlation.


Saving back to the NAS is currently not possible but a noted feature.  It requires that the receiving app also support a send back / open with… feature and many of the apps on iOS that have editing (e.g. quick office) don’t have this making the feature difficult to utilize.

Just tried this out on Android and so far it is working great.  Clipping is very handy for managing my music collection.  I have way too much to fit on my phone, but I can easily clip whatever I want to listen to on the go if it isn’t already on my phone.

I do have a suggestion for the future though.  It would be helpful if clipped folders would keep the same the folder names as on the My Book Live.  I mostly use folder browsing to listen to music, and right now any folder I have clipped shows up as a random string of characters. It would also be nice if it maintained folder structure when clipping, so that nested folders on the My Book Live would remain nested on my SD card instead of becoming flat.

Even with that slight drawback, this is still the most convenient way I’ve found to get media to my phone.  Keep up the good work!

Hi Raj

So my home router is A VirginMedia Super Hub, which I believe is actually a Netgear CG3101D.

When you mentioned Bonjour, I though it might be something to do with UPnP, which I had to adjust the settings for as it was causing my WD TV Live hub to restart every 30mins. So I adjusted UPnP Advertisement Period back to 30mins, restarted the router and WD 2Go Pro started to work across my internal network … then stopped working.

Changed the UPnP setting back to 1440mins, to stop my Live Hub from restarting constantly.

I do have a ‘Guest Wireless’ network setup, so will try your suggestion tonight and remove that to see if it has any effect.

Regarding the standard WD 2Go app, it has worked perfectly thoughout …


*** Update

Disabled Guest wireless - No Effect 

Restart Route - No Effect

Just wondering why saving back to NAS is not possible, as long as it can be supported natively in the ap (I’m not familiar with iOS, but am using Android).  The aps that I use support this feature using Dropbox (i.e. I can open word docs, pdfs, etc. on my HTC flyer, and save revisions back to Dropbox).  If I can ever get a prive NAS to support the same feature set as Dropbox, I’d be one happy camper (and buy that product in a heartbeat).  Maybe that is your goal, but just not quite there yet.


Hello! I have a similar problem on my ipad1 with programs D2go, WDPhotos. I can not go through a local network at MBL and I can not see the files and photos.With 3g everything is OK and I can see their files on the MBL. In my local network using router dlink dir-320. I hope to help, thank you.


D2Go and WDPhotos  begins to run on the local network after restarting ipad and after a while stops again. We also note that the connection status does not change even though the unit sees the files and shows all the time show  waiting.

Hi there guys,

Has there been any developments with this as yet?  I have exactly the same issue as some of the other guys with the “Device Offline - The Device is not accessible.  Local documents are available. (F.11)” error.

I have not tried wd2 go - I purchased the pro version.  

I entered the activation code correctly, and did it again to ensure it wasn’t an invalid code.

I can see that the authorisation is in a ‘waiting’ status on the MBL yet, I’m using WD Photo app also and that showed up as connected immediately and no issues accessing data.

Weird that one app works and another doesn’t.

That said, I DID have it working yesterday and, transferred about 130GB of music to the Shared Music folder… Some files showed up in there before I went to bed and in the morning - there was no music to be seen.

Now I can’t even get the thing to connect - installed and started over but nothing.

Please advise… 


*** Update ***

Further to my post above, I tried WD 2 GO (not the Pro version… which I bloody paid for) to see if that would connect…

… no issues at all.

In fact, can anyone tell me why I paid for a little bulldog clip anyway?  The free version is fine… it works… it’s free.

Please fix the paid version though, I paid money.

Having the same problems with Pro version - my Router is a Billion 7800N - free WD 2Go works fine but not the PAID FOR version…


Device Offline

The device is not accessible.  Local

documents are availiable. (F.11)

I have only tried local lan connection but I see others can connect via 3G.


try off “upnp” in router setting