WD20EARX poor performance


I know that this issue has been discussed here many times, but I’ve searched the forum and tried various suggestions, all with no success. I’m just trying to discover whether I didn’t miss some solution.

The problem is as follows:

We have bought two WD20EARS disks for our computing server to serve as a data storage (and one Velociraptor for system installation). Initially, we did run them in a Windows Server 2008 R2 software RAID (RAID 1) and did experience performance that was nothing short of awful. The transfer speeds from the RAID to the Velociraptor was around 30 MB/s which is slow, but still acceptable, however, write speeds never exceed 5-6 MB/s, often fell even under 1 MB/s, which is not acceptable at all.

I thought that the problem is, that it is just the Windows RAID that is performing poorly, so I disabled the RAID, removed one of the disks, reformatted the other and tried if the speeds got any better… and it didn’t. Therefore I think that the problem is either in the drive itself or in combination of the drive and motherboard.

The computer itself is a fairly powerful machine running 4 AMD Opteron 6128 processors, 64 GB RAM, all settled in a Supermicro H8QGL-iF+ motherboard. In the BIOS, the disks are set to operate in AMD_AHCI mode, which I assume should be correct. In Windows, the drivers for the SATA controller are updated to the latest version. I used a standard formatting tool in Windows 2008 Server R2 with default settings, which should be OK as per WD suggestion in the FAQ. I also tried to run the WD align utility, but it says that the disk is correctly aligned.

Finally, I’ve run the WD Diagnostics utlity and the drive passed all the test, that is: SMART test, QUICK test and even the EXTENDED test.

So my question is - is there anything more I could try before dumping the drives and buying another ones (or try to RMA the disks)?

Thanks for all suggestions!

Hi well we know that all green drives are not performance drives. They park the heads constantly and they use what is called intellipower so the drive will use 5400 rpm sometimes but a lot of the times they are under 5400 rpm they wont give us the minimum they run at but they are supposed to hit like 4500 rpm at times. Parking the heads will interfere with your raid. They are not recommended for boot drives only for storage. But even for storage they are ok if you don’t mind slow transfers. If they are in single mode they will still be slow on transfer of files but maybe not to the point yours are. You best bet is to contact WD and tell them the problems you are having.

We knew that the drives are not designed for perfomance - that is why we bought the velociraptor for the system drive. Nevertheless, I still think that the drives are performing too poorly. I have a similar drive in my home desktop PC and the write speeds are around 10 times faster than those we are experiencing on the server. Contacting WD surely is way to go, but it is the path I wanted to take as a last resort, I just wanted to find out if there is an “instant solution” to our problems.

Just to confirm you this is very low performing speed.

My WD20EARX can write at around 40-60MB/s with Win 7 x64 on a Asus Maximus Formula.

If you can, try your HD on another Mobo with Win7, and if the speed is still so slow, a drive hardware issue could be the reason ; if not, then it could be likely more a issue between the HD & the Mobo. So I’d also try the different HD modes in the BIOS, just to see if it changes the performances or not.

Also, check that a copy/paste of a large file on the WD20EARX (ie: not involving the Velociraptor) still gives low speed.

And the usual : turn off your antivirus, and any other program that may be fiddling with the file system.

I know this might be a bit late, but 40-60 MB/sec is low. My experience is this is typical for write times to the WD20EARX with very large 5GB-100GB+ files. Writng FROM a WD20EARX TO a WD15EADS (1.5 TB, several years old) I get a steady performance of around 80 MB/sec. I just finished writing a 340 GB file and got 81 MB/sec over the entire copy. If I do the reverse (from WD15EADS to WD20EARX) I get around 40 MB/sec. That’s a massive difference. The drives are in USB 3.0 docks connected to a Highpoint RocketU 1144A host adapter, which gives each dock its own CPU and channel. And both drives are green drives. I don’t know what the cause is, but when you are moving around massive files it makes a big difference in time (several hours).

I have the same issue with my new MOBO fom Intel. On the old MOBO worked welI, as I described it in this thread: