WD Utilities not compatible with MacOS 10.12

When WD utilities is installed on a Mac running MacOS Sierra, the utility fails on launch reporting that it is not being run from the Applications folder. Attached is a description of the problem.


Thank you for reporting the issue.
We’re working on it :slight_smile: Stay Tuned

1 Like

Any update (still having same problem with saying “Drive Utilities needs to be run from the Application Folder”.

Bump. Any update yet?

Or are there alternative software?

For those getting the Applications folder error, this seems to be a workaround. Launch the app by typing this command in a terminal window:

$ open /Applications/WD\ Drive\ Utilities.app/Contents/MacOS/WD\ Drive\ Utilities

jay2Utee: You are the man! Thanks for that…worked like a charm! :smile:

the command string is not working for me at this point… any update?


Another possible workaround would be to:

  • Copy the Drive Utility from the Applications folder to the desktop and copy it back

that actually worked… crazy… thanks…