WD TV Live Streaming Media Player Firmware 1.12.14

Hello there, yesterday I upgraded the firmware to the abovementioned version. After that it still finds my mediaserver (PS3 Media Server), but it is not able anymore to see any folders. It simply states that there are no folders available. The server worked with it before, it currently works with other clients. Does anyone else has this issue? COuld you please correct the firmware? This is the first time i have an issue after an update, although i am always nervous if everything will work afterwards. Cheers Ausbilder Schmidt

Hi, check if doing a rollback solves the issue. Check the link below for the steps.


Hello, if I understand it correctly the rollback-firmware will make the WD think that it is a much newer version. Will the device after that ever be able to receive firmware updates via the normal way? Kind regards AS

The rollback firmware only fools the player during that particular rollback and does not affect any other update.

Hi there,

the Rollback worked.

But the problem still exists.

The WDTV connects to PS3 mediaserver, but it keeps telling me that there are no files in the directories - neither using the “music” menu, nor using the “files” menu of WDTV

But thanks anyway .

Kind regards


The “.ver” file the updater sees with the firmware file is faked to show a newer version, typically 2.xx.xx. The actual firmware loaded will show the true number, 1.xx.xx.