WD TV Box won't find files on 3TB My Book

So I recently got a new HP laptop with Windows 10 on it as my previous one died. I have 2 external hard drives (a 3TB My Book that’s a year or so old, and a 1 TB that’s an older model) hooked up to one of the older WD TV boxes (doesn’t have netflix or wireless capabilities).

I put a couple of new episodes of a TV show on the 3TB My Book and when I hooked it back up to the WD TV box, it says that there’s no no media in the folder. I’ve hooked this My Book up to a newer TV box and it does the same thing. I then hooked my older My Book up to the laptop, moved the same files over, hooked it back up to the WD TV box and it works just fine. I’ve tried reformatting the My Book with the issues (at least I think I have) and still nothing works. Is there anything that can be done aside from buying a whole new My Book? I should also say that I can play all the files from the My Book when it is hooked up to the computer.

I have had a similar experience. See this post: https://community.wd.com/t/4tb-wd-no-longer-works/84611/10.

However now that Win 10 is pretty well established on a whim I tried other versions of chkdisk to see if I could still load my hard drive from a win 10 pc. I had a 3TB Seagate drive and the WD TV Live Hub only recognized a movie file if it was in the root folder. All other subfolders were “not there”.
I downloaded this version of chkdisk, http://www.majorgeeks.com/files/details/checkdisk.html and ran it on the drive before hooking up to the WD. This worked and now all subfolders were found and indexed.
There is something about Win10 and the drive interface that the OLD firmware on the WD does not recognize. Running this other chkdisk utility is a easy fix.

1 Like