WD Sync - The Remote Server Returned an Error: (401) Unauthorized

Hi everyone,

Just got the WD My Cloud Mirror GEN 2 and running F/W 2.21.119.

Been able to set it up and I can access it through my local network, WD Access, MyCloud.com and also MyCloud app on my iPhone (on my local wifi, through the cellular network and also from another public wifi network). I’m pretty sure the port forwarding and everything is working properly.

When I try to use WD Sync though, it’s giving me a popup window saying “The remote server returned an error: (401) unauthorized”.

I really want to run Sync and not map the drives as I need to use the files on a fast drive (my local SSD) but also synced with my other computers.

Any ideas or suggestions?

Hello,

  1. WD Sync uses the MyCloud.com Account username and password if your using remote sync.

  2. For local Sync, sign out of MyCloud.com and select the Mirror.
    This will use the local NAS username and password (not the mycloud.com credentials)

Sbrown,

Thanks for the reply. Didn’t even think of that. Tried it and it worked by logging in as the “admin”, but not as my user. I’ll look into that more, or if you have any comments, please share.

Just curious, do I need to switch it between signed in and signed out when I’m on my local network as opposed to an internet connection to the NAS remotely? That could be a bit of a pain…

Nope.
MyCloud.com is only needed for when you want to us WD Sync from a remote PC like your place of employment or something.

I suggest using the user account and keep Admin for Administration stuff.

OK, I can live with logging in and logging out depending on if my laptop is at the office or off-site. Bit of a pain, but workable…

It’s interesting that I get the same error message when I log in as any other user besides “admin”.

This is going to be an issue as I have 4 users that need to access this drive, and I need to control which shares they have access to. I’ll need some assistance on this also.

If you’re logged into your PC as “username” then WD Sync will create C:\Users\username\WD Sync when you configure WD Sync with the username of your NAS.

So if you try to use WD Sync with a different NAS username on the same PC without being a different users on that PC, C:\Users\username\WD Sync is already created and you’ll get the same error message.

I checked and there is no directory like that. The closest I have is a
C:\Users\Username\My Cloud. I tried erasing that, but the same issue.

You may need to email support for assistance with this one, if you haven’t already.

Thanks… I have already… Was just hoping for a quicker answer here… Might try uninstalling and re-installing…

I’ll post if anything gets resolved, or let me know if anything else comes to mind.

Created a test account and that one works… Seems to be just locking up on a specific account…

Think I found the issue… Seems that I might have deleted the default folder for that user on the NAS drive, so that was causing me not to be able to log in. I deleted that user, added a new one with the same name and now it’s working fine (even when I’m logged in through MyCloud.com)

Hope this helps someone in the future!

I got same problem and i found the problem why, reason go to " My Cloud EX2 web interface —> Users-----> Click User name which user name you are using for WD sync --------->Check the " Share Acces " you have to click Read/Write section for WDSync folder. Otherwise if you choose just for read or Deny Acces your user name can’t acces to WDsync.exe