WD MyCloud LED Solid Orange for more than 10 hours

This device does not use for several months. At first I can open it by Network tab in Windows 10 but it’s too slow. For example, copying 2mb image is so slow and suddenly it stops and then I disconnected. So I signed in mycloud.com. I opened it but not for long. I saw that my MyCloud is full and there’s a popup message that need to update (firmware I guess). I clicked then it shows Downloading Bar but I immediately plugged the power out and LAN cable because I realize how it can update if it’s full? After 10 seconds I plugged the power and LAN. I wait more than 5 minutes and the LED still Orange. I tried to check the router’s network status and I didn’t saw it’s MAC address or its name. I signed in again mycloud.com and it says it can’t connect to WDMyCloud. I want to reset but I don’t have back config for it. How am I suppose to do? Can I still get my files there? Can I unbrick it and the put the HDD to my PC?

Thank you for helping me!

You can perform a 40 second reset of the My Cloud unit by following the steps detailed in the following WD Support document:


1 Like

What if more than 20 minutes and it’s still solid orange? Any other way to fix it?

I do 40 second reset of the My Cloud and I wait more than 10 hours and still LED is solid orange? What should I do now?

Is the LED orange or red? Red generally indicates a problem with the internal hard drive. Other troubleshooting steps.

Connect the My Cloud to a different networking port on the router.
If using AT&T Uverse there is a known problem between the AT&T supplied router and the My Cloud, the workaround is to use a switch between the My Cloud and router. See this link for more information.
Try a different networking cable.
Connect the My Cloud direct to the computer’s networking port and see if problem persists.

In the end one may have to contact WD Support directly and open a trouble ticket.


Is it orange or red?

I saw the manual but I dont see orange led so it’s red. But according to the manual it should blinking but it’s solid. I felt the top of MyCloud is warm (not too hot). Is the problem is internal? How can I fix this? @Bennor @MCKAYUK