WD MyCloud Gen2 - Enable apps install tab + Apps!


#332

I realize this is not really the place for this. But what about those who want to do something’s to the wireless pro drive?


#333

I have no idea if there is any relationship between the MyCloud and MyPassport products, or if there is any firmware commonality. My guess would be not, or very tenuous.

Try posting on the relevant forum:

https://community.wd.com/c/wd-external-drives/my-passport-wireless

#334

can you please share this update? I don’t know how to do that on my end but would greatly appreciate it.

thanks!


#335

Sure.

There you go.


#336

Thank you so much! Was it easy to convert this file? I wanted to learn so I wouldn’t bug people for updates every time.


#337

Well it wasn’t that difficult to begin with, because @elliots helped me with pretty detailed explanation, so I am going to pass it on to you.

What you need:

  • some linux system(I just used virtual ubuntu 16.04 32bit(tried with 17.04 64bit didn’t work).
  1. Opened plex server and got the notification that my plex server is outdated and proceeded to download it. In my case that was https://downloads.plex.tv/plex-media-server/1.10.1.4602-f54242b6b/WDMyCloudEX2_plexmediaserver_11014602-f54242b6b.bin. Created a new folder and used wget command to get it.
  2. In order to create the package, you have to have their tool. http://developer.mycloud.com/MCDSDKindex.html (Section 3). The direct link to get it is http://developer.mycloud.com/sdkdocs/mksapkg so just got that with wget.
  3. Set the permissions for the file with chmod +x mksapkg (or you can use simply the sudo command when starting it).
  4. Creating tar package from it with:
    “dd if=WDMyCloudEX2_plexmediaserver_11014602-f54242b6b.bin of=WDMyCloudEX2_plexmediaserver_11014602-f54242b6b.tar.gz bs=200 skip=1”
    It created from the downloaded package WDMyCloudEX2_plexmediaserver_11014602-f54242b6b.bin a tar package which I can unpack later on in order to be able to extract what I need. The package created is the one which we wanted “WDMyCloudEX2_plexmediaserver_11014602-f54242b6b.tar.gz”.
  5. We have to unpack it with the command “tar -zxvf WDMyCloudEX2_plexmediaserver_11014602-f54242b6b.tar.gz” where it unpacked everything onto the folder plexmediaserver.
  6. Enter the folder with “cd plexmediaserver”.
  7. Now we have to create it. If you did your chmoding properly, then use “…/mksapkg -m WDMyCloud” and if not, just add sudo in front of it to run it as root. With it we start the mksapkg app and tell it to create the package for the modem (hence -m) for WDMyCloud.

In my case, the file was not named .bin afterwards but it had an additional number. Just rename it to end with .bin.

I can post the files onto the dropbox folder, since I am using it daily and will try to have the latest plex version available.

Hoped it helped.


#338

Could you please share the bin? :smiley:


#339

It’s like three posts above your request…


#340

Sorry! I typed that ages ago! Account just got verified and that post became like! Cheers mate


#341

Ended up building it myself between waiting for my account to be verified :stuck_out_tongue:


#342

hello from portugal… can we have a new Milestone Arcus Surveillence app… the old one has expired license…

thank you


#344

How is the WDMyCloud_WDCrack_1.0.bin file created? Also how is it executable? All three if the WDCrack_1.x.bin files have Glacier as the first 7 characters. Which is not the beginning of a executable type of file. The WDMyCloud_WDSleepFix_1.0.bin file also has Glacier as the first 7 characters. Interesting that the files are for the Gen2 My Cloud. Which is Code: GLCR - Glacier. Would like to be avle to create and extract this file type.

Any help would be appreciated.


#345

Packing tool from “WD GPL Source code archive”: https://fox-exe.ru/WDMyCloud/Other/WD_Apps_Make/
For unpack app (.bin) just cut first 200 byte of data (Header):
dd if=app.bin of=app.tar.gz bs=200 skip=1
About this header: https://fox-exe.ru/WDMyCloud/Other/WDMC%20App%20info.txt (Russian)


#346

Thanks for the information. Still not sure how the file executes.


#347

Not executes. Just unpacked to /mnt/HD/HD_a2/Nas_Apps/app_name
Then - starts “install.sh” (Or “init.sh”?). After reboot - start “start.sh” or “stop.sh”


#348

Thanks again. I finally found that the package does not execute but gets installed by an app on the Gen2.


#349

no one can help me on milestone arcus license expiracy


#350

I think we are alone in using arcus, is also abandoned from milestone, asked few time where to buy (but should be free) to theyr support with no reply

They disabled acquiring new licenses in July 2017, than enable for like 1month (and I was very lucky to install 2camera and automatically got 2 license for these) than now disabled again and I’m unable to add more cameras

I think the issue is present also on the EX version of MyCloud and the only way to use is an adhoc patch…

ps. i also noticed that is impossibile to restart via web ui arcus, when you put the Run App: switch of will stop the arcus server but will stuck on updating… and also refreshing the page will not allow to restart arcus putting the switch on, the only way to restart arcus is to folly reboot the nas


MyCloud Gen2 custom apps mini repository
#351

is your xml generation script down?

btw actually i’m on firmware 2.30.181 looking at the WDMycloud Homepage, uname -a say

Linux WDMyCloud 3.10.39 #1 SMP Fri Aug 5 11:16:40 CST 2016 2014T20p4 Build-git3f24b4d armv7 GNU/Linux

i still havn’t understand whats wrong, but if i want to install new apps i need to put the code in the chrome console and remove the display: none; part on the install app block


#352

thank you for your reply… do we have any alternative? i did have the 2 free license cameras but it expired at 31/12/2017… i only have those 2 camera but now the arcus just says it need atencion because of expired license… any other software i can put on mycloud so it records?