WD MyCloud Gen2 - Enable apps install tab + Apps!


#271

I have also same problem to install WDCrack.
I am following the steps from post #1, then I am able to install the application first WDCrack - still it is fine.

But when is installation done, there is no change, if reloading the web page nothing new is available - I mean there is no new application(WDCrack) in the apps section and install link/button is hidden again.
I tested all version WDCracks:
WDMyCloud_WDCrack_1.0.bin
WDMyCloud_WDCrack_1.1.bin
WDMyCloud_WDCrack_1.2.bin

Any idea what is wrong?


#272

Great thanks!


#273

What you need to do is

  1. Log on to your WD My Cloud dashboard
  2. Open up the Console within your browser
  3. Copy and paste this into the Console - APP_INSTALL_FUNCTION=1; APPS_EULA=1; check_app_eula();
  4. Press enter
  5. Close Console
  6. Navigate to the Apps page within the dashboard
  7. You should now see the option at the top to install apps - install WD My Crack.

#274

Is the Console something inside the Dashboard? If so where would I find it? (I looked at all my tabs and don’t see it).

If not, where do I find the Console in Firefox browser?

(you are referring to a Gen 2 Single Bay My Cloud, right?)

Thanks for any info!


#275

Hi,
Is there a way to build app based on the Twonky new version files? Plex is to heavy for me and I was looking for upgrading it.
Anybody tried it before or built any other app from scratch?

Twonky source 8.4.1 download link

UPDATE: I have managed to succesfully install new Twonky 8.4.1 without unbricking it - just via ssh.
I have used dirty way as its code is not .BIN so not installable via GUI. I have installed any other app from Fox repository, copied Twonky server to its location and used start.sh file to run my Twonky instead of original app.
When you will forsce new Twonky to use same folder to keep its database/config (-appdata parameter) it will work as a charm.

Of course WD old Twonky server needs to be disabled.


#276

I see.

So the offered version could not be simply used.

Would you please tell me how to use this command mksapkg? Where to use ti :slight_smile:

Thank you.


#277

update Twonky 8.4.x successfully installed


#278

Not sure what “console” PeverillJames is talking about but there are two “console” options in Firefox under Tools > Web Developer. Web Console and Browser Console.


#279
https://community.wd.com/search?context=category&context_id=105&expanded=true&q=Mkapkg

#280

hi !!! Is so cool so i need your help for finish my project…
i try to install any version of debian or ubuntu
so when i chroot buildenv
the dir is emty
how can make_…env
and see my file i try on ssh on direct on pc

thx
fcailloux@mail.com


#281

Problem is that when I trying to accept the agreement to install the manual app then nothing will be happened and the not accepted the agreement

can anyone help me please?


#282

It was described in this topic before.
close this window and open console in Chrome.
next steps:
Press [ctrl] + [shift] + [i], open “Console” tab, put this and hit [enter]:
APP_INSTALL_FUNCTION=1; APPS_EULA=1;

if this window will appear again use this on the console:

$("#AppsDiag_Manually_Install").remove();
var input = '<input type="file" name="f_apps_file" class="file_input_hidden" id="f_apps_file" onchange="apps_manually_install();">Install an app manually</div>';
$("#manually_install_td").append(input);

it worked for me many times.


#283

Anyone has a link for the new update from plex ? :slight_smile:


#284

I installed Fox_exe’s Dropbox app for my WD NAS. However, I get a Connection Error in a new page when I attempt to configure the Dropbox app. Do you have any ideas why this is happening?


#285

@zylstra Use this new Dropbox version https://drive.google.com/open?id=0B6Hz6MrfAWvAWENiWXl1N0hKR00

Dropbox has disabled the previous API, so using the 1.X version will not be able to connect, you need version 2.00


#286

Thanks, @franfj. Is there a tutorial on how to make my own bin files? Did you create this one?


#287

Still no update for Arcus?

Can someone give some info to repack by myself?


#288

i’ve updated WDCrack app from 1.0 to 1.2 but i still see “No available Apps.” in the App Store


#289

Not sure if Fox updated his app to have apps list built-in now. But you can always go to his app repository here: http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen2/Apps/
Then manually install the bin file.


#290

Try stop-start the WDCrack (Its force update app list).
Also check - if my website available from NAS (ping anionix.ddns.net)

Also you can manually update apps list:
sudo curl http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen2/Apps/apps_xml_gen.php > /var/www/xml/app_info.xml
(And i think there is problem - sudo w/o any flags may faul to run. Need check it, but i dont want to rollback firmware (Im on Debian 9.2 (stretch) now - successful updated from jessie via apt dist-upgrade!))