WD MyCloud Gen2 Chroot (+ Transmission and Minidlna)

Thank you very much, but how to install aria2 and let it autostart ?

Hi, need help.

I loaded the package and can see minidlna is working

My problem is I got a command line that can run outside Chroot, but due to dependency, I need to run inside the Chroot

I put the executable inside Chroot in the folder /usr/newfoldername, and chmod 777 * +R, run the file using ./newprogram
The system return bash: ./newprogram: No such file or directory

I am not a linux expert and do not know how to make it works.

Please help. Thanks

cd /usr/newfoldername ./yourprogramm
or

or store your program in one of default locations (/sbin, /usr/bin, /usr/sbin) and just type “newprogram” in any folder for run your program.

Note: Use /usr/sbin folder for your program (executable), /etc for configs, /usr/var for store variables (pid files and other), /var/log for logs and /usr/local for additional data (Default linux folders)

Hi, I got the same issue. Tried the suggested alternate by Dennis3001, but
still facing the same. Download starts, runs for a while and stops.
Could any one help, pls

In Transmission I get Error: Unable to save resume file: Permission denied,What to do?please help

How to move downloaded files to WD My Cloud Public folder,so i can access them from my computer?

hi everyone,

i have a my cloud gen2. i replaced a new hdd. but it didnt work.

i read this and i did one by one.

especially i tried this a lot of
https://ftp.anionix.ru/WDMyCloud/

fox,
can you help me?

Nevermind,got it working :wink:

Please detail what you did to get it working in case others have a similar problem or issue.

1 Like

Sure,this is what i did.

  1. Upload archive to any shared folder (In Public for example)
  2. Tur on “SSH access” in Web-gui.
  3. Set Username: Username
  4. Set password: Password
  5. Download PuTTY (or any other ssh client), connect to WDMC ( IP of WD My Cloud ).
    Using SSH username and password ( Usernam:Password )
  6. Run this in console:
    cd /mnt/HD/HD_a2/Public
    tar xvf chroot-jessie-gen2.tar -C …/
    /mnt/HD/HD_a2/chroot/chroot-debian.sh start

If Errors

7.Go inside chroot env.:
chroot /mnt/HD/HD_a2/chroot/ /bin/bash

8.run this in console ( remove and reinstall )

apt-get purge transmission-daemon
apt-get autoremove
apt-get install transmission-daemon

9.Setting up transmission

On Webadmin create share called “Temp”

go inside chroot

chroot /mnt/HD/HD_a2/chroot/ /bin/bash

and run this.

service transmission-daemon stop

nano /var/lib/transmission-daemon/info/settings.json

change :

“download-dir”: “/mnt/shares/Temp”,
“incomplete-dir”: “/mnt/shares/Temp”,
“unmask”: 0

Change Username and password
Defult username is: transmission
Defult Password is: password

Save and Exit and run this.

chmod 777 /mnt/shares/Temp/ -R

service transmission-daemon start

That`s it

1 Like

I installed the package the following the steps in 1st message. What should I do if I want to revert the changes?

I followed the steps from the OP.

After I install transmission and bash chroot stop and start the application I get the following:

[warn] Starting bittorrent daemon: transmission-daemon (warning).

with what appears to be the daemon up and running.

I attempted to access the application, but I am getting no pop up GUI. Should I be using the Transmission Remote GUI, and if so why am I getting an access denied when I try to log in?

If need be, I can cite my run commands start to finish. I supposed I should also mention I am running OS 10.11.

Latest FW have internal torrent-client (“P2P” in apps). Its Transmission, but w/o web gui, only RPC (Remote Connection / Transm. Remote GUI). Maybe P2P already started and listen this port.

In the webGUI, I see no P2P in apps. In the TRGUI I am getting 403: Forbidden, Unauthorized access…json “rpc-whitelist” so on…

Stop trans, edit config.json (Disable whitelist, or change user/pass/allowed IP’s)

Thanks, everything is working great

Hi all,

I have done the first steps and seems like everything is in place but, can anyone tell me how to run transmission once the installation process is finished?

formerly I had an WD myBook live running transmission via 192.168.0.134:9091 but now i´m trying to access and there is no way :frowning:

thanks for the great work!

Victor

I can’t see it in apps so does that meant it’s not installed? I’ve installed TRG but can’t seem to connect.

Any advice most welcome.

Update:

I can see the Minidlna as a source on my Smart TV but still don’t know how to access Transmission…

I think - port 9091 used by internal transmission daemon (Hidden “P2P” app).
Try to change port in settings.json.
And use “Transmission Remote GUI” as client.

Thank you but I just get “Connection refused”.