WD mybook not working


I have purchased a Black 3TB mybook drive for pc (https://www.wdc.com/en-gb/products/wd-recertified/my-book.html?gclid=CjwKCAjwxJnNBRAMEiwA8X_-Qd5VnaLv_xWzd4nxqTSgSj2I52iWwvq0_UXdU-7KTLs99T8oe4KnpRoCPacQAvD_BwE#RWDBFJK0030HBK-EESN). I opened the enclosure of the 3TB and placed this in my dlink nas device. The 3TB drive acts as a secondary drive for another 3TB WD red drive (i.e. Raid 1 configuration). This works fine.

I have an old WD green 2TB drive which I wanted to place in the enclosure. This wd 2tb green drives works via the sata connection of the pc and using a sata to USB 2 cable.

windows does not let me use the drive. It shows up in disk storage as need initialising. When I select it, I am prompt with gpt or mbr options. Selecting either one gives me a failed message. The sata to USB 3.0 for the mybook enclosure label shows

4060 705149-000 REV A

Is there anyway I can reuse the enclosure? Does the drive need to be formatted in a certain way with specific partitions or bit set ?

Thank you

Hi Taiuk10 ,

Well if you want to use the 2TB WD Green drive in NAS enclosure, make sure that the drive is of the same capacity i.e.3TB. However, it wont be configured in the way it is right now.


Hi Peter

Thank you for your quick reply but I think you misunderstood me. I want to use the Wd green 2TB drive in the my book enclosure. When I place the wd drive in the enclosure it is not recongnised by windows. It ask me to change it to mbr or gpt. When I select one or the other it errors. Drive is not usable.


I have 4 WD My Passports work excellently for over 2 to 7 years.

I also had bought a 1TB WD My Book AV(Also called DVR Expander 2.0, which with an eSATA and an USB ports, PIN: WDBABT0010HBK-00, S/N: Wcc4420325) on 7/9/2014. Then I used the eSATA cable to connect it to a RCN HD TiVo cable box (Model: TCD746320, which has 320 GB recording space for recording HD TV programs). They had worked well for a few months and they stop working( even could not watching TV). When I disconnected the WD My Book AV, the TiVo cable has worked until now. Then I had been busy help my two grandchildren preparing, applying and get into CMU and Cornell respectively, so, I had no time to handle this problem.

I suspected that the WD My Book has broken? But I might be wrong.

Now I think may be because the WD My Book AV has triple storage capacity than the TiVo, may be the TiVo recording was full so it could not handle the situation and stopped working. If so, my 5 Western Digital storage devises are all in excellent condition for over 2 to 7 years. I hope they will make a long life record.

So, we need to find out a way to prove that my WD My Book AV is still good.

I’m asking if I can use a USB cable to connect this WD My Book AV to my Windows 7 Desktop Computer to see if the WD My Book AV can be used as a storage devise as WD My Passport do?

Your help will be highly appreciated.