WD My Passport Ultra - Device failed?

I have an issue with my 1TB WD Ultra.  It worked fine till this morning, then all when I plugged in it wouldnt appear under my drives as normal.

The drive isnt hidden in any way, when I manage drives under disk management I get an ‘Initialise Disk’ message, click ok to this and then get a ‘Request could not be performed because of an I/O device error’.

Within the WD Smartware it shows but has a red X and says ‘No writable partition found’.

Within the WD Smart Apps, theres a Diags screen and when i run smart status it comes back as failed.

The quick drive and complete drive tests dont seem to run.

Anything else I could try?  a colleague of mine had the same driv ebut it was encrypted and the exact same thing happend toi his after 3 months … mines lasted 6.


 Hello there,

Welcome to the WD Community.

 As a recommendation, try using the drive with a different USB cable since the I/O error is normally related to the connection either on the drive or the PC that you are using. 

Test the drive on a different computer. If stills the same, contact WD Support for direct assistance.

Thanks … I tried 4 different USB cables and 3 different machines, that was the first thing I tried.

Initially it did show in the WD apps software and showed the total storage of the device, now it just says My Passport and withing Windows device manager it shows 0mb.

This is the 2nd WD device that we have had this happen to now.

I could contact support, but suspect data is lost in which case its destined for the bin, very frustrating.

pls help my WD My Passport Ultra disk formated unfortunately how can i unformated

Once formatted I wouldnt have thought the data would be easily recovered!

I found the solution, kind of… 

I had given a colleague a copy of most of the software that was on mine (as we are ICT techs) so copied it back off him.

I have now ordered a couple of Toshiba USB HDD drives as my last one lasted 4 years before I broke the USB connector.

In a nutshell, of the 3 WD drives we bought, only one remains operational/hasnt failed.  Disspapointing really, and mines now in the disposal pile.


Wow. This is pathetic. My drive is connecting to my Mac but has failed.

I have to treat my Passport as nothing more than an expensive thumb drive as it is not a professional storage solution.

Is there not even a cloud backup? If the device is this unreliable then this should be available.