WD LIVE won't turn on

My WD Live will not power on.  The last time it updated firmware and was fine, but now it will not turn on.  New batteries in remote did not help.

Any ideas?


How are you connected to the TV?  

If via HDMI, try using the composite cable (when HDMI handshake fails, the unit reverts to Composite connection).

Or does the power light not come on at all?  That sounds a tad more serious…

As Grant said try the composite video connection plus unplug from power for some minutes and then plug back in. The WDTV should come automatically (front light on). Also with unit on press side paperclip reset button, the unit should now reboot.

I have the exact same problem, wont turn on after the update with the remote. Only way to turn it on is to unplug and replug power. That will make it turn on and it functions normally, but the next time you turn it off its the same again.

Have you tried the overkill reset:

reset via the side paperclip button with the unit on

reset to factory defaults via the internal menu

unplug from the power for some minutes, not seconds.

do all 3 before using the unit again

This is recommended after a firmware update particularly if you experience problems.

I don’t think this is related to the recent firmware update. It happened to me about a week ago, before the firmware update on ONE of my WD LIVE devices. Both devices had the same beta firmware, don’t recall which one but it was not the most recent. One unit would power on via the remote, the other would not. The only significant difference is that the working device had been left on for a long time and the problem unit had been off for maybe a week.

Tried various things on the problem unit- new batteries in the remote, cleaning the remote transmitter window, cleaning the receiver window. Nothing worked. Definitely know the problem was before the current firmware update because on the problem unit I had pull the plug to get it  to reboot and see the new update.

Now, magically, the problem unit is working again. The only thing I did was to go through and review the settings, did not change anything but I probably did hit save a few times. I have also left it on for a few days, so maybe this has something to do with the problem.

Does not seem very rational but this is what happened to me.

I’m having the exact same problem as the first poster.   Mine was completely fine before the last firmware, but now every time I turn it on, I have to unplug it to sort of “reset” it and then it’s fine again, until I turn it off.  

I have tried unplugging the power for a few hours.

I have tried factory defaults.

I have tried without USB Drives (Only Network line)

I have tried without Network One. (Only USB)

I have even tried this with ONLY the power cord connected.

It will just not power on (White Power Light) until I physically unplug the unit and then plug it back in again, and then all is fine.  

This has happened about three days ago when I updated with this last update.

Anyway of rolling this back???  OR letting WD know about this issues?

Thanks, Gjohnlue.

Yes, you can roll it back.  Look in the FIRMWARE forum for instructions.

There definitely is an issue with Remote Power On with 1.03.49. I’ve never got this issue before, but it appears now after upgrade, especially after a long power off. I have the “old” Live, the non-green version (and yes, I did all the resets after upgrading …)


Exact same problem here since firmware upgrade.

It has nothing to do with the recent upgrade.

Mine exhibited this under 1.02.21.  If I kept using it regularly, the remote was fine for turning it “on” and “off”.

But if I leave it untouched for an extended time, then it won’t turn back on from standby with the remote – I have to power cycle it.