WD HD TV Live with Media-server


#1

Has somebody an practical experience in usage WD HD TV Live with Mediaserver? I’m trying to broadcast internet (http) video/audio streams from my computer (Ubuntu, Mediatomb) to WD HD TV Live, but it is not successful. What mime-types does it support? Could somebody advice corresponding software and/or tutorial?


#2

I’m wondering the same. There isn’t much information in the user manual about the media server source. However I think I read somewhere that DLNA is supported and I saw no mention of UPnP.


#3

Hello,

Yes, DNLA is supported, I’ve activated the DNLA server on my Synology NAS and can play the media from there.

I’ve had nearly no issue so far but I’ve the WD since 2 days only and have not updated the micro code.

My WD is wired connect to a Gigabit switch (even if the WD network card is 100mb/s)  where the NAS is wired connect as well.

My router is a linksys wrt54gl under tomato, I’ve set up a fixed IP for the WD on the router side based on WD MAC address.

I’ve mainly played SD content (xvid) and quickly tested HD one, but as I still have a CRT TV I’m not connected by HDMI.

Small gap so far, when selecting videos and selecting my NAS as source, the WD shows me the 3 music/photo/video folders and doesn’t limit itself to the video part. Same applied for photo & music.

I’ve not tested yet direct shares access, my workgroup name is not ‘WORKGROUP’ but this doesn’t seems to create problems while using DNLA access (I don’t see why it should BTW).

David


#4

Video and music from shared folder as well from local files on UPnP server are played without any special problems. The problem exists if you try to play an internet video (like free tv) stream. For video upto now i see only traffic flow and no image or sound. At the present time audio (like free internet radio) stream works well.

My configuration: system - Ubuntu, sharring program - Samba, UPnP server - Mediatomb, video stream generated from VLC.


#5

You say that you’re able to stream internet radio through MediaTomb? It seems that this doesn’t work at home… Any particular MediaTomb setting that should be enabled for this to work? Do you have to enable VLC transcoding for this to work? Did you just create an URL item in MediaTomb, or did you create a playlist with the URL inside?

Thanks a lot for any hint :slight_smile:


#6

About internet radio:

Default MediaTomb settings (as I unterstood without transcoding etc.). Then I add in web interface an external url

" http://sc2.frf.llnw.net:80/stream/gffstream_w20a" (this url from m3u file from http://www.radiobremen.de/funkhauseuropa/#, see “Livestream einschalten”), mime-type “audio/mp3”. Now I can not remember which item type I used. Any way it was the same like if you add a local audio file.

P.S. I can also send you my .mediatomb/config.xml file if it will help.


#7

That’s a marvelous idea to try to set the mime type as it should be :slight_smile:

However I think the correct mime type is audio/mpeg. With audio/mp3 it doesn’t seem to work. I’m trying audio/mpeg right now, with “object.item.audioItem.musicTrack” as the class (although maybe another class would be more appropriate but I couldn’t find the possible classes anywhere). I’ll post the restults when I can…

Thanks


#8

The class type which I put was just “object.item.audioItem”. With “audio/mpeg” and “audio/mp3” I am not sure but any way one of them worked well :slight_smile:


#9

That’s strange: it really doesn’t work on my end. (I put audio/mpeg for the mime type, and object.item.audioItem as the Upnp class). This creates a file the WDTV Live tries but fail to play. Then, I get the same result as when URLs are embedded in a standard playlist: the spinning waiting animation of death, as described in this thread.

Do you use the most recent non-bricking firmware (1.01.11)? Are you able to simply play streams embedded in m3u or pls playlist files? I wonder what is wrong with my setup…


#10

So about internet radio on WD HD TV Live + MediaTomb. It works, but only audio. The properties of an exemplar item from MediaTomb are below. To import them I just write url’s and titles in .pls file and add it into mediatomb database.

// Firmware 1.0.11, MediaTomb 0.12

Title: Bremen Eins
URL: http://gffstream.ic.llnwd.net/stream/gffstream_mp3_w48a
Protocol: http-get
Class: object.item.audioItem.musicTrack
Description: Song from radio.pls
Mimetype: audio/mpeg

#11

Well duh… now it works :)  Thanks a lot, not sure what I did wrong before. I think I was trying to embed URLs inside playlists objects, whereas using the External URL objects works…


#12

I have made bad experience with my media server… :cry:

Using a WHS with Twonky version 5.1

Several files did not play, mainly I had issues with MKV files. The WD did see those files as ‘unknown type’

Accessing via SMB is perfect!

Regarding IPTV or InternetRadio: I did try this with Twonky, but it did not work. All together with the other problems, I just gave up here.

Bottom line: Do not waste your time playing around with Twonky…

Best,

Timo


#13

Well all streams are not created equal it seems. For example, streams from Digitally Imported don’t work with the settings suggested above for Media Tomb. It even makes the player process crash, and I must unplug and re-plug the WDTV Live for it to work again properly.

Interestingly, the stream which works ( Bremen Eins), when launched in Firefox, makes it launch a player plugin and plays instantly. Whereas for example, the DI Ambient stream URL, when opened in Firefox, shows a webpage describing the stream… Maybe it should not be accessed using http-get?

This is maybe more a question to ask on Media Tomb’s forums though.

So in summary, your mileage may vary.


#14

Actually I am using Twonky Media and have no problems with MKV files.  Works Great!